hdu4371 Alice and Bob---博弈------多校联合8

Alice and Bob

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 99    Accepted Submission(s): 62


Problem Description
Alice and Bob are interested in playing games. One day, they invent a game which has rules below:
1. Firstly, Alice and Bob choose some random positive integers, and here we describe them as n, d1, d2,..., dm.
2. Then they begin to write numbers alternately. At the first step, Alice has to write a “0”, here we let s1 = 0 ; Then, at the second step, Bob has to write a number s2 which satisfies the condition that s2 = s1 + dk and s2 <= n, 1<= k <= m ; From the third step, the person who has to write a number in this step must write a number si which satisfies the condition that si = si-1 + dk or si = si-1 - dk , and si-2 < si <= n, 1 <= k <= m, i >= 3 at the same time.
3. The person who can’t write a legal number at his own step firstly lose the game.
Here’s the question, please tell me who will win the game if both Alice and Bob play the game optimally.

Input
At the beginning, an integer T indicating the total number of test cases.
Every test case begins with two integers n and m, which are described before. And on the next line are m positive integers d1, d2,..., dm.
T <= 100;
1 <= n <= 106;
1 <= m <= 100;
1 <= dk <= 106, 1 <= k <= m.

Output
For every test case, print “Case #k: ” firstly, where k indicates the index of the test case and begins from 1. Then if Alice will win the game, print “Alice”, otherwise “Bob”.

Sample Input
  
  
2 7 1 3 7 2 2 6

Sample Output
  
  
Case #1: Alice Case #2: Bob

Author
standy from UESTC

Source

Recommend
zhuyuanchen520
 
选一个最小的di
#include<iostream>
#include<cstdlib>
#include<stdio.h>
using namespace std;
int main()
{
    int t,n,m;
    int cc=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int mm=1000010;
        int num;
        for(int i=0;i<m;i++)
        {
            scanf("%d",&num);
            if(num<mm)
            mm=num;
        }
        int s=0;
        printf("Case #%d: ",cc++);
        int count=0;
        while(s<=n)
        {
            s+=mm;count++;
        }
        if(count%2==0)
        cout<<"Bob"<<endl;
        else
        cout<<"Alice"<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值