poj3372 Candy Distribution---找规律

教师按特定规律给围绕圆圈编号的N个孩子分糖果,从第1个和第2个开始,依次跳过1个孩子给下一个糖果,然后跳过2个孩子再给下一个,以此类推。程序需判断所有孩子能否至少得到一颗糖果。输入为正整数N(2≤N≤1,000,000,000),输出为“YES”或“NO”,表示所有孩子是否都能得到糖果。" 5713862,537253,Java 调用 .NET Web Service 教程,"['java开发', 'web服务', '.net开发', '跨平台调用', 'axis']
摘要由CSDN通过智能技术生成
Candy Distribution
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5071 Accepted: 2767

Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3 
4

Sample Output

YES
NO
YES

Source

2的n次幂YES~~~
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    long long n;
    while(scanf("%I64d",&n)!=EOF)
    {
      int cc=0;
      while(1)
      {
          long long res=pow(2,cc+0.0);
          if(res==n){puts("YES");break;}
          if(res>n){puts("NO");break;}
          cc++;
      }
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值