扩展欧几里得&&中国剩余定理 解线性同余方程组 专题

poj1061  扩展欧几里得解方程

#include<iostream>
#include<cstdlib>
#include<stdio.h>
using namespace std;
__int64 exGcd(__int64 a,__int64 b, __int64 &xx, __int64 &yy);
int main()
{
       __int64 x,y,m,n,L,xx,yy;
       scanf("%I64d%I64d%I64d%I64d%I64d",&x,&y,&m,&n,&L);
       __int64 d=exGcd(n-m,L,xx,yy);//a,n,x,y  ax+ny=b;(n-m)*xx+l*yy=x-y;
       if((x-y)%d!=0)
              cout<<"Impossible"<<endl;
       else
       {
              xx=xx*((x-y)/d);
              int s=L/d;
              xx=(xx%s+s)%s;
              printf("%I64d\n",xx);

             /* xx=(x-y)/d*xx%L+L;
              printf("%I64d\n",xx%(L/d));*/

              /*e = b / d * x % n + n;
              return e % (n / d);*/
       }
       system("PAUSE");
       return 0;
}
__int64 exGcd(__int64 a,__int64 b, __int64 &xx, __int64 &yy)
{
       if(b == 0)
       {
       xx = 1;
       yy = 0;
       return a;
       }
       __int64 r = exGcd(b, a % b, xx, yy);
       __int64 t = xx;
       xx = yy;
       yy = t - a / b * yy;
    return r;
}

Poj2115

C Looooops

Time Limit: 1000MS  Memory Limit: 65536K

Total Submissions: 11401  Accepted: 2700

Description

A Compiler Mystery: We are given a C-language style for loop of type

for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16

3 7 2 16

7 3 2 16

3 4 2 16

0 0 0 0

Sample Output

0

2

32766

FOREVER

这题与上题大同小异。

根据题意,我们有A+CX=B(mod M)  M=1<<k

cx+2^ky=b-a
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<math.h>
using namespace std;
__int64 exGcd(__int64 a,__int64 b, __int64 &xx, __int64 &yy);
int main()
{
       __int64 xx,yy,a,b,c,k;

       while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k)!=EOF)
       {
        if(a==0&&b==0&&c==0&&k==0)
        break;
        k=pow(2,k+0.0);
        __int64 d=exGcd(c,k,xx,yy);//a,n,x,y  ax+ny=b;(n-m)*xx+l*yy=x-y;
       if((b-a)%d!=0)
              cout<<"FOREVER"<<endl;
       else
       {
              /*xx=xx*((x-y)/d);
              int s=L/d;
              xx=(xx%s+s)%s;
              printf("%I64d\n",xx);*/

              xx=(b-a)/d*xx%k+k;
              printf("%I64d\n",xx%(k/d));

              /*e = b / d * x % n + n;
              return e % (n / d);*/
       }
       }
      // system("PAUSE");
       return 0;
}
__int64 exGcd(__int64 a,__int64 b, __int64 &xx, __int64 &yy)
{
       if(b == 0)
       {
       xx = 1;
       yy = 0;
       return a;
       }
       __int64 r = exGcd(b, a % b, xx, yy);
       __int64 t = xx;
       xx = yy;
       yy = t - a / b * yy;
    return r;
}

Poj2142

The Balance

<

Time Limit:5000MS

Memory Limit:65536K

Total Submissions:2337

Accepted:1012

  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值