[sicily online]1028. Hanoi Tower Sequence

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Hanoi Tower is a famous game invented by the French mathematician Edourard Lucas in 1883. We are given a tower of n disks, initially stacked in decreasing size on one of three pegs. The objective is to transfer the entire tower to one of the other pegs, moving only one disk at a time and never moving a larger one onto a smaller. 

The best way to tackle this problem is well known: We first transfer the n-1 smallest to a different peg (by recursion), then move the largest, and finally transfer the n-1 smallest back onto the largest. For example, Fig 1 shows the steps of moving 3 disks from peg 1 to peg 3.

Now we can get a sequence which consists of the red numbers of Fig 1: 1, 2, 1, 3, 1, 2, 1. The ith element of the sequence means the label of the disk that is moved in the ith step. When n = 4, we get a longer sequence: 1, 2, 1, 3, 1, 2, 1, 4, 1, 2, 1, 3, 1, 2, 1. Obviously, the larger n is, the longer this sequence will be.
Given an integer p, your task is to find out the pth element of this sequence.

Input

The first line of the input file is T, the number of test cases.
Each test case contains one integer p (1<=p<10^100).

Output

Output the pth element of the sequence in a single line. See the sample for the output format.
Print a blank line between the test cases.

Sample Input

4
1
4
100
100000000000000

Sample Output

Case 1: 1
 
Case 2: 3
 
Case 3: 3
 
Case 4: 15

题目分析:

1,大整数,肯定用string类型来表示

2,看例子:

1:1

2:121

3:1213121

4:121312141213121

可以发现规律第n组是(n-1的数据)+n+(n-1组的数据)

还有一个规律是数列121312141213121,其中,1,2,3的出现都是等间隔的,若要求n  n%2=1的话 结果就是1 n%4=2结果就是2 n%8=3 结果就是3

可以看出n一直除以2 除的次数+1 就是结果

#include<iostream>
#include<stdio.h>
#include<cmath>
#include<iomanip>
#include <vector>
#include <string>
#include <algorithm>
#include <sstream>
using namespace std;

//返回值为string为除数  int为余数
pair<string,int> strMod(string x1,int x2)
{
	int num=0;
	string result;
	for(string::size_type i=0;i<x1.size();i++)
	{
		num=num*10+(x1[i]-'0');
		int tmp=num/2;
		num=num%x2;
		result=result+(char)(tmp+'0');
	}
	while(1)
	{
		if(result.size()==1)
			break;
		if(result[0]=='0')
			result.erase(result.begin());
		else break;
	}
	return make_pair(result,num);
}

int main()
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		string data;
		cin>>data;
		cout<<"Case "<<i+1<<": ";
		int count=0;
		for(string::size_type j=0;;j++)
		{
			pair<string ,int> tmp=strMod(data,2);
			data=tmp.first;
			if(tmp.second==0)
			{
				count++;
			}
			else break;
		}
		cout<<count+1<<endl;
		if(i!=n-1)
			cout<<endl;
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值