hdu 5938 Four Operations 贪心

Four Operations

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 69    Accepted Submission(s): 31


Problem Description
Little Ruins is a studious boy, recently he learned the four operations!
Now he want to use four operations to generate a number, he takes a string which only contains digits  ’1’ -  ‘9’, and split it into  5 intervals and add the four operations  ‘+’‘-‘‘*’ and  ‘/’ in order, then calculate the result(/ used as integer division).
Now please help him to get the largest result.
Input
First line contains an integer  T , which indicates the number of test cases.
Every test contains one line with a string only contains digits  ’1’- ‘9’.
Limits
1T105
5length of string20

Output
For every test case, you should output  ’Case #x: y’, where  x indicates the case number and counts from  1 and  y is the result.
Sample Input
1
12345

Sample Output
Case #1: 1

代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>
#include<list>
#define mem(x,y)memset(x,y,sizeof(x))
#define max(a,b)(a)>(b)?(a):(b)
#define min(a,b)(a)<(b)?(a):(b)
#define INF 1e18
#define eps 1e-10
#define M 10000000007
using namespace std;
typedef long long int LL;
const int maxn=100005;
char s[maxn];
LL getNumber(int ii,int jj)
{
    int i;
    LL sum=0;
    LL num=1;
    for(i=jj; i>=ii; i--)
    {
        sum+=(s[i]-'0')*num;
        num*=10;
    }
    return sum;
}
int main()
{
    int T,i,j,k,l;
    int num=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        LL maxx=-INF;
        LL num1,num2,num3,num4,num5;
        LL xx;
        for(i=2; i<=len-3; i++)
        {
            num1=getNumber(0,i-2);
            num2=getNumber(1,i-1);
            xx=max((num1+s[i-1]-'0'),(num2+s[0]-'0'));
            num3=s[i]-'0';
            num4=s[i+1]-'0';
            num5=getNumber(i+2,len-1);
            //printf("%I64d %I64d %I64d %I64d %I64d\n",num1,num2,num3,num4,num5);
            xx-=num3*num4/num5;
            if(xx>maxx)maxx=xx;
        }
        printf("Case #%d: %I64d\n",num++,maxx);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值