POJ 2377 Bad Cowtractors(Kruskal算法)

Bad Cowtractors
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7944 Accepted: 3392

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

Source

//Kruskal算法

//求出n个点构成的最大生成树,如果可以则输入最大权值和,否则输出-1

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

#define N 1001
struct point {
    int u, v, w;
}pnt[20001];

int set[N], rank[N];

bool cmp(struct point p1, struct point p2) {
    return p1.w > p2.w;
}

void make_set(int n) {
    for(int i = 0; i <= n; i++) {
        set[i] = i;
        rank[i] = 1;
    }
}

int find_set(int x) {
    int j, k, r;
    r = x;
    while(r != set[r]) {
        r = set[r];
    }
    k = x;
    while (k != r) {
        j = set[k];
        set[k] = r;
        k = j;
    }
    return r;
}

void merge(int x, int y) {
    int xx = find_set(x);
    int yy = find_set(y);
    if(xx == yy) return;
    if(rank[xx] > rank[yy]) {
        set[yy] = xx;    
        rank[xx] += rank[yy];
    } else {
        set[xx] = yy;
        rank[yy] += rank[xx];
    }
}

int main()
{
    int i, cnt, total, n, m;
    while(scanf("%d%d", &n, &m) != EOF) {
        for(i = 0; i < m; i++)
            scanf("%d%d%d", &pnt[i].u, &pnt[i].v, &pnt[i].w);
        make_set(n);
        sort(pnt, pnt+m, cmp); cnt = 0;
        for(i = 0, total = 0; i < m; i++) {
            if(find_set(pnt[i].u) != find_set(pnt[i].v)) {
                cnt += 1;
                total += pnt[i].w;
                merge(pnt[i].u, pnt[i].v);
            }
        }
        if(cnt != n-1)
            printf("-1\n");
        else
            printf("%d\n", total);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值