hdoj pbd



/*PBD
Problem Description

PrisonBreak is a popular TV programme in HDU. ACboy likes it very much,
and he join a PrisonBreak discussing team called "PBD".Every Tuesday night,
a lot of PBDers will contact with each other to discuss the newest plot of PrisonBreak
season2. Generally speaking, every PBDer has distinct ideas about the play,
so everyone want to know all the others' ideas. For example, when ACboy contract with Sam,
ACboy will tell all the ideas he konws to Sam, and Sam will also tell all the ideas he
konws to ACboy, and the call costs 5 yuan.
If there are N people in the "PBD" team, what is the minimum cost to let everyone
knows all the others' ideas?

Input

The input contains multiple test cases.
Each test case contains a number N, means there are N people in the "PBD" team.
N = 0 ends the input.(A call cost 5 yuan).


 


Output

for each case, output a integer represent the minimum cost to let everyone knows all
the others' ideas.

Sample Input

1
2
3
4
0

Sample Output

0
5
15
20

Hint

If there are 2 people, for example, named A, B. Then A calls B,
then A and B will know each other's ideas, so it only
needs one call, so the minimum cost is 1*5 = 5 yuan.*/

<span style="font-size:18px;">#include<stdio.h>
int main()
{
    int n,i,m;
    while(scanf("%d",&n),n!=0)
    {
     if(n==1 || n==2) 
     printf("%d\n",5*(n-1));
     if(n==3 || n==4)
     printf("%d\n",5*n);
     if(n>=5)
     {  for(m=4,i=5;i<=n;i++)
        m=m+2;
           printf("%d\n",m*5);
     }
    }
    return 0;
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值