FZU 2150 Fire Game (双起点BFS)

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.


Input


The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board.

Then goes N line, each line with M character shows the board. “#” Indicates the grass.

You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10


Output


For each case, output the case number first, if they can play the MORE

special (hentai) game (fire all the grass),

output the minimal time they need to wait after they set fire, otherwise just output -1.

See the sample input and output for more details.


Sample Input


4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#


Sample Output


Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2
 

 #代表草堆,问能否找到两个起点烧完所有的草堆并且要使时间最短


 火势蔓延的方向数组仍旧是普通BFS的四个方向


 数据范围很小,10*10,记录所有的草堆位置,两两暴力BFS即可

   

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<map>
#include<algorithm>
#include<iostream>
#define ll long long
#define ull unsigned long long
const int N=1e9+7;
const int M=15;
using namespace std;

char a[M][M];      //存放地图
int b[4][2]= {1,0,-1,0,0,1,0,-1}; // 方向数组
int c[M][M],d[105][2],e,f,l;
int i,j,k,n,m;

struct node
{
    int x,y,step;
};

void init()
{
    e=0,l=0;
    memset(d,0,sizeof(d));
}

bool check(int x,int y)
{
    return x>=0&&y>=0&&x<n&&y<m&&a[x][y]=='#'&&!c[x][y];  //检查是否合法
}

int bfs(node g,node h)
{
    memset(c,0,sizeof(c));
    queue<node>q;
    q.push(g),q.push(h);
    c[g.x][g.y]=1, c[h.x][h.y]=1;
    f=2;           // f代表广搜烧的草堆数
    node r,t;
    while(!q.empty())
    {
        r=q.front();
        q.pop();
        for(k=0; k<4; k++)
        {
            t.x=r.x+b[k][0];
            t.y=r.y+b[k][1];
            if(check(t.x,t.y))
            {
                t.step=r.step+1;
                c[t.x][t.y]=1;
                f++;
                if(f==e) return t.step;      //烧完所有的草堆时  跳出广搜
                q.push(t);
            }
        }
    }
    return 0;
}

int main()
{
    int T,u=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        init();
        for(i=0; i<n; i++) scanf("%s",a[i]);
        printf("Case %d: ",++u);
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(a[i][j]=='#')
                {
                    d[l][0]=i, d[l][1]=j;        //记录草堆位置
                    e++,l++;                          //  记录草堆数
                }
            }
        }
        if(e<=2)
        {
            printf("0\n");   //草堆数小于等于2时 直接输出0
            continue;
        }
        int ans=N;
        for(i=0; i<l; i++)
        {
            for(j=1; j<l; j++)
            {
                node c1,c2;
                c1.x=d[i][0],c1.y=d[i][1],c1.step=0;
                c2.x=d[j][0],c2.y=d[j][1],c2.step=0;
                int y=bfs(c1,c2);              //两两暴力
                if(y) ans=min(ans,y);
            }
        }
       if(ans!=N) printf("%d\n",ans);
       else printf("-1\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值