[POJ 1330]Nearest Common Ancestors(LCA最近公共祖先)

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

Source

1、比较简单一些的LCA算法,具体做法如下:

具体代码如下

#include <iostream>
#include <cstring>

#define MAXN 10010

using namespace std;

int f[MAXN]; //f[a]=b表示a的父亲是b

int lca(int u,int v) //求u和v的树上公共祖先
{
    if(u==v) return u; //找到了树上公共祖先
    int w;
    while(u)
    {
        w=f[u];
        f[u]=0; //将f[u]与u之间的连接断开
        u=w;
    }
    for(;v;v=f[v]) //v向上遍历,找到第一个没有父亲的点,就是答案
        if(!f[v]) return v;
    return 0;
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        memset(f,0,sizeof(f));
        cin>>n;
        for(int i=1;i<n;i++)
        {
            int u,v;
            cin>>u>>v; //有向边u->v
            f[v]=u; //v的父亲是u
        }
        int a,b;
        cin>>a>>b; //最后一行a,b是求lca(a,b)
        cout<<lca(a,b)<<endl;
    }
    return 0;
}
2、tarjan LCA离线算法

#include <iostream>
#include <vector>
#include <cstring>

#define MAXN 10010

using namespace std;

vector<int>son[MAXN]; //保存树
vector<int>ques[MAXN]; //保存查询
typedef vector<int>::iterator it;

int inDegree[MAXN];
int f[MAXN];
int ancestor[MAXN]; //ancestor[i]=点i的祖先
bool visit[MAXN];
int ans,n;
int depth[MAXN];

void pre_work()
{
    for(int i=1;i<=n;i++)
    {
        f[i]=i;
        inDegree[i]=0;
        depth[i]=1;
        visit[i]=false;
        ancestor[i]=0;
        son[i].clear();
        ques[i].clear();
    }
}

int findSet(int x)
{
    if(f[x]==x) return x;
    return f[x]=findSet(f[x]);
}

void Union(int a,int b)
{
    int roota=findSet(a);
    int rootb=findSet(b);
    if(roota==rootb) return;
    else if(depth[roota]<=depth[rootb])
    {
        f[roota]=rootb;
        depth[rootb]+=depth[roota];
    }
    else
    {
        f[rootb]=roota;
        depth[roota]+=depth[rootb];
    }
}

void lca(int u) //tarjan lca
{
    int Size=son[u].size();
    ancestor[u]=u; //标记u的祖先为u
    for(int i=0;i<Size;i++) //遍历u的儿子
    {
        lca(son[u][i]);
        Union(u,son[u][i]);
        ancestor[findSet(u)]=u;
    }
    visit[u]=true;
    Size=ques[u].size();
    for(int i=0;i<Size;i++)
    {
        if(visit[ques[u][i]]==1)
        {
            cout<<ancestor[findSet(ques[u][i])]<<endl;
            return;
        }
    }
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n;
        pre_work();
        for(int i=1;i<n;i++)
        {
            int u,v;
            cin>>u>>v;
            inDegree[v]++;
            son[u].push_back(v);
        }
        int a,b;
        cin>>a>>b;
        ques[a].push_back(b);
        ques[b].push_back(a);
        for(int i=1;i<=n;i++)
        {
            if(inDegree[i]==0) //从入度为0的点开始tarjan lca
            {
                lca(i);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值