Rectangles
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 30752 Accepted Submission(s): 9980
Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
Sample Output
1.00
56.25
至于为什么要:
resx1 = max(x1, x3), resy1 = max(y1, y3)
resx2 = min(x2, x4), resy2 = min(y2, y4)
看上图:就是能够相交矩阵的左下角和右下角
AC Code:
#include<iostream>
#include<sstream>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<map>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<list>
#define mod 998244353
#define INF 0x3f3f3f3f
#define Min 0xc0c0c0c0
#define mst(a) memset(a,0,sizeof(a))
#define f(i,a,b) for(int i=a;i<b;i++)
using namespace std;
typedef long long ll;
const int maxn = 1e6 + 5;
const double pi = acos(-1);
int n, m, v;
int main(){
double x1, y1, x2, y2, x3, y3, x4, y4;
while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf", &x1, &y1, &x2, &y2, &x3, &y3, &x4, &y4) != EOF){
if(x1 > x2) swap(x1, x2);
if(x3 > x4) swap(x3, x4);
if(y1 > y2) swap(y1, y2);
if(y3 > y4) swap(y3, y4);
double resx1 = max(x1, x3);
double resx2 = min(x2, x4);
double resy1 = max(y1, y3);
double resy2 = min(y2, y4);
if(resx1 > resx2 || resy1 > resy2) printf("0.00\n");
else printf("%.2f\n", (resx1 - resx2) * (resy1 - resy2));
}
return 0;
}