HDU2069 Coin Change (DFS)

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23934    Accepted Submission(s): 8373


 

Problem Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11

26

Sample Output

4

13

 题意:

用1,5,10,25,50五种面值的硬币组成面值为n的硬币

坑点在于英文题...硬币总数<=100没看清,WA了一下

数据不大,深搜就行

看很多大佬都是dp和母函数过的,待会去学习一波

#include<iostream>
#include<sstream>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<map>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<list>
#define mod 998244353
#define INF 0x3f3f3f3f
#define Min 0xc0c0c0c0
#define mst(a) memset(a,0,sizeof(a))
#define f(i,a,b) for(int i=a;i<b;i++)
using namespace std;
typedef long long ll;
const int maxn = 1e6 + 5;
const double pi = acos(-1);
const int v[5] = {1, 5, 10, 25, 50};
int n;
int res;
void dfs(int sum, int ans, int s, int num){ 
    //sum表示当前组成的面值,ans代表n值,s代表搜索深度(0,4),num代表硬币数
    if(num > 100) return ;
    if(sum == ans){
        res++;
        return;
    }
    if(sum > ans) return;
    for(int i = s; i < 5; i++){
        if(sum + v[i] > ans) return;
        dfs(v[i] + sum, ans, i, num + 1);
    }
}
int main(){
    while(scanf("%d", &n) != EOF){
        if(n == 0){
            printf("1\n");
            continue;
        }
        res = 0;
        for(int i = 0; i < 5; i++){
            dfs(v[i], n, i, 1);
        }
        printf("%d\n", res);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值