POJ 3468A Simple Problem with Integers 线段树(成段增减 & 区间求和)

                                   A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 146302 Accepted: 45477
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

线段树成段增减 & 区间求和(懒惰标记)

AC Code:

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
using namespace std;
typedef long long ll;
static const int MAX_N = 1e5 + 5;
ll segtree[MAX_N << 2];
ll vv[MAX_N << 2];

void PushUp(int rt){
    segtree[rt] = segtree[rt << 1] + segtree[rt << 1 | 1];
}
void PushDown(int rt, int l){
    if(vv[rt]){
        vv[rt << 1] += vv[rt];
        vv[rt << 1 | 1] += vv[rt];
        segtree[rt << 1] += (l - (l >> 1)) * vv[rt];
        segtree[rt << 1 | 1] += (l >> 1) * vv[rt];
        vv[rt] = 0;
    }
}
void build(int l, int r, int rt){
    vv[rt] = 0;
    if(l == r){
        scanf("%lld", &segtree[rt]);
        return ;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void update(int L, int R, int v, int l, int r, int rt){
    if(l >= L && r <= R){
        segtree[rt] += (ll)(r - l + 1) * v;
        vv[rt] += v;
        return ;
    }
    PushDown(rt, r - l + 1);
    int m = (l + r) >> 1;
    if(L <= m) update(L, R, v, lson);
    if(R > m) update(L, R, v, rson);
    PushUp(rt);
}
ll query(int L, int R, int l, int r, int rt){
    if(l >= L && r <= R){
        return segtree[rt];
    }
    PushDown(rt, r - l + 1);    //懒惰标记
    int m = (l + r) >> 1;
    ll res = 0;
    if(L <= m) res += query(L, R, lson);
    if(R > m) res += query(L, R, rson);
    return res;
}

int main(){
    int n, q;
    char s[5];
    while(~scanf("%d%d", &n, &q)){
        build(1, n, 1);
        while(q--){
            scanf("%s", s);
            if(s[0] == 'Q'){
                int l, r;
                scanf("%d%d", &l, &r);
                printf("%lld\n", query(l, r, 1, n, 1));
            }
            else {
                int l, r, v;
                scanf("%d%d%d", &l, &r, &v);
                update(l, r, v, 1, n, 1);
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值