PTA L2-012 关于堆的判断 (最小堆)

                                    L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

 数据结构:堆

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<queue>
#include<climits>
#include<set>
#include<stack>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
static const int MAX_N = 1e3 + 5;
int heap[MAX_N];
int n;
void insert(int x) {	//堆排序建最小堆
	while (heap[x >> 1] > heap[x] && x != 1) {
		int temp = heap[x >> 1];
		heap[x >> 1] = heap[x];
		heap[x] = temp;
		x >>= 1;
	}
}
int find_parent(int x) {	//父节点
	int i;
	for (i = 1; i <= n; i++) {
		if (heap[i] == x) break;
	}
	return heap[i >> 1];
}
int main() {
	int m;
	scanf("%d%d", &n, &m);
	scanf("%d", &heap[1]);
	for (int i = 2; i <= n; i++) {
		scanf("%d", &heap[i]);
		insert(i);
	}
	while (m--) {
		int v1;
		char s1[10];
		scanf("%d%s", &v1, s1);
		if (s1[0] == 'i') {
			char s2[10], s3[10];
			scanf("%s%s", s2, s3);
			if (s3[0] == 'r') {
				if (v1 == heap[1]) printf("T\n");
				else printf("F\n");
			}
			else if (s3[0] == 'p') {
				char s4[3];
				scanf("%s", s4);
				int v2;
				scanf("%d", &v2);
				if (find_parent(v2) == v1) printf("T\n");
				else printf("F\n");
			}
			else if (s3[0] == 'c') {
				char s4[3];
				scanf("%s", s4);
				int v2;
				scanf("%d", &v2);
				if (find_parent(v1) == v2) printf("T\n");
				else printf("F\n");
			}
		}
		else {
			int v2;
			char s2[10], s3[10];
			scanf("%d%s%s", &v2, s2, s3);
			if (find_parent(v1) == find_parent(v2)) printf("T\n");
			else printf("F\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值