浙大PTA数据结构Pop Sequence

该篇博客讨论了如何判断给定的序列是否为一个最大容量为M的栈,在依次压入1到N的数字后,随机弹出可能产生的序列。输入包含M、N和K,其中K是需要检查的弹出序列数量。对于每个弹出序列,如果可能从栈中得到,则输出'YES',否则输出'NO'。
摘要由CSDN通过智能技术生成

02-线性结构3 Pop Sequence

Given a stack which can keep MMM numbers at most. Push NNN numbers in the order of 1, 2, 3, …, NNN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MMM is 5 and NNN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MMM (the maximum capacity of the stack), NNN (the length of push sequence), and KKK (the number of pop sequences to be checked). Then KKK lines follow, each contains a pop sequence of NNN numbers. All the numbers in a line are separated by a space.
Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include <iostream>
#include <stack>
#define Max 1000
using namespace std;
//给出一段有序数字,判断能否从栈中弹出得到对应的顺序
int main()
{
    stack<int> s;
    int i,j,f,x,cnt;
    int M,N,K;
    int A[Max];
    cin>>M>>N>>K;
    while(K--)
    {
        cnt=0;j=1;                                             //cnt为能否成功的标记,每次循环j都是从1开始压栈
        for(i=0;i<N;i++) cin>>A[i];
        for(i=0;i<N;i++)                                       //从第一个数字遍历
        {
            if(s.empty())                                      //判断栈顶是否为空
             {
                    for(;j<=A[i];j++)                          //从当前j元素一直压栈j,j+1,..直到压到A【i】元素
                    s.push(j);
                    if(s.size()>M) {cnt++;break;}              //判断此时栈长是否超过限制,超过则说明此时得到A【i】元素不合理,即错误

                   x=s.top();                                  //x保存即将弹出的栈顶元素
                   s.pop();                                    //栈顶元素和A【i】对应,弹出
                   continue;

             }
              if(x>A[i])                                       // 如果之前栈顶元素x即A【i-1】比此时的A【i】元素大,则应该
             {
                x=s.top();                                     //比较当前栈顶元素与A【i】是否相等,相等则正确,弹出栈顶元素x
                if(x==A[i]) s.pop();
                else {cnt++;break;}                            //不相等则错误

             }
             else if(x<A[i])                                   //如果A【i-1】比此时的A【i】元素小,则应该从当前的j开始压栈,j+1,j+2..直到压到A【i】
             {
                 for(;j<=A[i];j++)
                    s.push(j);
                if(s.size()>M) {cnt++;break;}                   //如果超过栈的大小限制,则说明不能得到A【i】元素,故退出
                 x=s.top();
                 s.pop();
                 continue;
             }


        }
        if(cnt==1)
            cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
        while(!s.empty())                                      //每次循环后,要清空栈,防止栈中元素对下次循环的影响
                s.pop();

    }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值