poj 2503 map应用 与 C 输入问题

Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41067 Accepted: 17494

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.


题目大意:
将右端的单词翻译成左端的单词,如果字典中没有,则输出eh。

分析:
用map解决配对问题
while(gets(str))            //输入一行字符串
    {
        if(strcmp(str,"\0")==0) break;
        sscanf(str,"%s %s",str1,str2);     //  只读取不输入,读取 str 中 两个被空格隔开的字符串 给str1,str2         
    }

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <map>
using namespace std;

int main()
{
    map<string,string> m;
    char str1[50],str2[50],str[101];
    while(gets(str))
    {
        if(strcmp(str,"\0")==0) break;
        sscanf(str,"%s %s",str1,str2);
        m.insert(pair<char *,char *>(str2,str1));
    }
    map<string,string>::iterator it=m.begin();

    while(gets(str))
    {
        if(m.find(str)!=m.end())
             printf("%s\n",m[str].c_str());
        else
            printf("eh\n");
    }

    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值