Just a Hook
http://acm.hdu.edu.cn/showproblem.php?pid=1698Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.Now Pudge wants to do some operations on the hook.
Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.
Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.Sample Input
110
2
1 5 2
5 9 3
Sample Output
Case 1: The total value of the hook is 24.题意
钩子有许多金属条组成,将连续金属棒从1到N编号。对于每次操作,可以将连续的金属棒(从X到Y编号)改为铜棒,银棒或金棒。 钩的总值计算为N个金属棒的值的总和。更确切地说,每种棒的价值计算如下:对于每个铜棒,值为1.
对于每个银棒,值为2.
对于每个金棒,值为3.
计算执行操作后钩子的总值。
原来的钩子是由铜棒组成的。
#include<stdio.h>
#include<algorithm>
#include<cstring>
#include<iostream>
#define lson root<<1
#define rson root<<1|1
using namespace std;
const int maxn = 1e5+5;
int sum[maxn<<2],add[maxn<<2];
void pushup(int root)
{
sum[root]=sum[lson]+sum[rson];
}
void pushdown(int root,int m)//向下更新节点
{
if(add[root])//当add[root]不等于0时,说明root下面的子节点的金属条的种类都是val
{
add[lson]=add[root];//子节点的金属条的种类等于父节点的
add[rson]=add[root];
sum[lson]=add[root]*(m-(m>>1));//现在的sum[lson]并不是正真的sum[lson],只有在给最
sum[rson]=add[root]*(m>>1);//底层赋值后在向上更新后,才会是真正的sum[lson]
add[root]=0;
}
}
void build(int l,int r,int root)
{
add[root]=0;//初始化
if(l==r){
sum[root]=1;
return ;
}
int m=(l+r)/2;
build(l,m,lson);
build(m+1,r,rson);
pushup(root);
}
void update(int s,int e,int val,int l,int r,int root)
{
if(s<=l&&r<=e) {
sum[root]=(r-l+1)*val;
add[root]=val;
return ;
}
pushdown(root,r-l+1);
int m=(l+r)/2;
if(s<=m)
update(s,e,val,l,m,lson);
if(m<e)
update(s,e,val,m+1,r,rson);
pushup(root);
}
int main(void)
{
int n,m,ca;
scanf("%d",&ca);
for(int i=1;i<=ca;i++)
{
scanf("%d%d",&n,&m);
build(1,n,1);
while(m--) {
int s,e,val;
scanf("%d%d%d",&s,&e,&val);
update(s,e,val,1,n,1);
}
printf("Case %d: The total value of the hook is %d.\n", i, sum[1]);//输出sum[1]
}
return 0;
}