程序设计基础41 tips 关于数组从后往前遍历

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

一,注意点

1,开的数组长度是max_n,应当从max_n-1开始遍历到下标为0的,不能从max_n开始。

二,代码

#include<cstdio>
using namespace std;
const int max_n =2020;
double arr[max_n]={0};
struct Polynomial{
	int ex;
	double coe;
}pol[13];
int main(){
	int num_1=0;
	int num_2=0;
	int K=0;
	double Nk=0;
	scanf("%d",&num_1);
	for(int i=0;i<num_1;i++){
		scanf("%d %lf",&pol[i].ex,&pol[i].coe);
	}
	scanf("%d",&num_2);
	for(int i=0;i<num_2;i++){
		int a=0;
		double b=0;
		scanf("%d %lf",&K,&Nk);
		for(int j=0;j<num_1;j++){
			a=K+pol[j].ex;
			b=Nk*pol[j].coe;
			arr[a]+=b;
		}
	}
	int ans=0;
        /************************************
         ************************************
        从max_n-1开始遍历*********************/
	for(int i=max_n-1;i>=0;i--){
		if(arr[i]!=0){
			ans++;
		}
	}
	printf("%d",ans);
	for(int i=max_n-1;i>=0;i--){
		if(arr[i]!=0){
			printf(" %d %.1f",i,arr[i]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值