程序设计基础71 STL之queue中的小问题

1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

一,细节问题

1,关于如何遍历留下尾巴的分组的问题。

我的代码:

for (int i = 0; i < group; i++) {
	int id = 0;
	int max_id = que.front();
	que.pop();
	if (i != group - 1) {
		for (int j = 1; j < NG; j++) {
			id = que.front();
			que.pop();
			if (rice[id].weight > rice[max_id].weight) {
				rice[max_id].rank = group + 1;
				max_id = id;
			}
			else {
				rice[id].rank = group + 1;
			}
		}
		que.push(max_id);
	}
	else {
		for (int j = 1; j < NP - NG*(group - 1);j++) {
			id = que.front();
			que.pop();
			if (rice[id].weight > rice[max_id].weight) {
				rice[max_id].rank = group + 1;
				max_id = id;
			}
			else{
				rice[id].rank = group + 1;
			}
		}
		que.push(max_id);
	}
}

标准代码:

for (int i = 0; i < group; i++) {
	int k = que.front();
	for (int j = 0; j < NG; j++) {
	    if (i*NG + j > NP)break;
	}
}

2,关于本题可以统一对同一分组的遍历为同一个组号,那些误判的在以后的几轮中会被更正过来。

二,我的AC代码(非标准)

#include<cstdio>
#include<queue>
using namespace std;
const int max_n = 1100;
struct Rice {
	int id, weight, rank;
}rice[max_n];
queue<int> que;
int main() {
	int NP = 0, NG = 0, real_NP = 0;
	int co_weight = 0, co_id = 0;
	int group = 0;
	scanf("%d %d", &NP, &NG);
	real_NP = NP;
	for (int i = 0; i < NP; i++) {
		scanf("%d", &co_weight);
		rice[i].id = i;
		rice[i].weight = co_weight;
	}
	for (int i = 0; i < NP; i++) {
		scanf("%d", &co_id);
		que.push(co_id);
	}
	while (NP != 0) {
		if (NP % NG != 0) {
			group = NP / NG + 1;
		}
		else {
			group = NP / NG;
		}
		for (int i = 0; i < group; i++) {
			int id = 0;
			int max_id = que.front();
			que.pop();
			if (i != group - 1) {
				for (int j = 1; j < NG; j++) {
					id = que.front();
					que.pop();
					if (rice[id].weight > rice[max_id].weight) {
						rice[max_id].rank = group + 1;
						max_id = id;
					}
					else {
						rice[id].rank = group + 1;
					}
				}
				que.push(max_id);
			}
			else {
				for (int j = 1; j < NP - NG*(group - 1);j++) {
					id = que.front();
					que.pop();
					if (rice[id].weight > rice[max_id].weight) {
						rice[max_id].rank = group + 1;
						max_id = id;
					}
					else{
						rice[id].rank = group + 1;
					}
				}
				que.push(max_id);
			}
		}
		NP = group;
		if (NP == 1) {
			rice[que.front()].rank = 1;
			NP--;
		}
	}
	for (int i = 0; i < real_NP; i++) {
		printf("%d", rice[i].rank);
		if (i != real_NP - 1) {
			printf(" ");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值