The 2014 ACM-ICPC Asia Mudanjiang Regional Contest - K

Known Notation

Time Limit: 2 Seconds       Memory Limit: 131072 KB

Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

  1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
  2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

Output

For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

Sample Input
3
1*1
11*234**
*
Sample Output
1
0
2
题意:有两种操作一种是添加数字或者符号,另外一种是交换两个字符的位置,使用最少的操作数使该字符满足RPN。
解法:其实是贪心,当数字数量小于或者*数量的时候才进行插入操作,其他都用交换,但首先看字符串是否全部是数字,如果是则直接输出0,如果含有*,则判断*的数目和数字的数目,满足数字数量小于或者*数量的条件就在ans+=(*数量-数字数量)+1,数字的数量则为刚才添加的数量:(*数量-数字数量)+1,而*数量则初始为0,然后逐个字符判断下去,当*数量=数字数量的时候,进行交换操作,因为一个*要对应两个数字,从最后一位开始判断,找到s[j]为数字的时候就Swap(s[i],s[j]),ans++,*数量-1,数字数量+1,这样判断到字符串最后一位。然后最后还要判断一下交换完之后最后一位是否是数字如是数字则ans++。
#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define inf 0x0f0f0f0f
using namespace std;
#define max 110
int main()
{
    int t,ans;
    int i,left,right,l,j,k;
    int cnt1,cnt2;
    int flag;
    char s[1005];
    scanf("%d",&t);
    while(t--)
    {
        flag=0;
        ans=0;
        cnt1=cnt2=0;
        scanf("%s",s);
        l=strlen(s);
        left=0;
        right=l-1;
        for(i=0;i<l;i++)
        {
            if(s[i]>='1'&&s[i]<='9')
                cnt1++;
            if(s[i]=='*')
                cnt2++;
        }
        if(cnt1==l)
        {
            printf("0\n");
            continue;
        }
        if(cnt2>=cnt1)
        {
            ans+=(cnt2-cnt1)+1;
            cnt1=(cnt2-cnt1)+1;
        }
        else
            cnt1=0;
        cnt2=0;
        for(i=0;i<l;i++)
        {
            if(s[i]>='1'&&s[i]<='9')
                cnt1++;
            if(s[i]=='*')
                cnt2++;
            if(cnt1==cnt2)
            {

                for(j=right;j>=i;j--)
                {
                    if(s[j]>='1'&&s[j]<='9')
                    {
                        swap(s[j],s[i]);
                        ans++;
                        cnt2--;
                        cnt1++;
                        break;
                    }
                }
            }
        }
        if(s[l-1]!='*')
            ans++;
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值