UVA—11464

11464 Even Parity
We have a grid of size N × N. Each cell of the grid initially contains a zero(0) or a one(1). The parity
of a cell is the number of 1s surrounding that cell. A cell is surrounded by at most 4 cells (top, bottom,
left, right).
Suppose we have a grid of size 4 × 4:
1 0 1 0 The parity of each cell would be 1 3 1 2
1 1 1 1 2 3 2 1
0 1 0 0 2 1 2 1
0 0 0 0 0 1 0 0
For this problem, you have to change some of the 0s to 1s so that the parity of every cell becomes
even. We are interested in the minimum number of transformations of 0 to 1 that is needed to achieve
the desired requirement.
Input
The first line of input is an integer T (T < 30) that indicates the number of test cases. Each case starts
with a positive integer N (1 ≤ N ≤ 15). Each of the next N lines contain N integers (0/1) each. The
integers are separated by a single space character.
Output
For each case, output the case number followed by the minimum number of transformations required.
If it’s impossible to achieve the desired result, then output ‘-1’ instead.
Sample Input
3
3
0 0 0
0 0 0
0 0 0
3
0 0 0
1 0 0
0 0 0
3
1 1 1
1 1 1
0 0 0
Sample Output
Case 1: 0
Case 2: 3

Case 3: -1


题意:白书例题。先枚举第一行可能的情况,然后通过第一行推出下一行。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL  long long
#define inf 0x0f0f0f0f
using namespace std;
#define MAXN 20
int A[MAXN][MAXN],B[MAXN][MAXN];
int n;
int solve(int s)
{
    int cnt=0;
    memset(B,0,sizeof(B));
    int i,j;
    for(i=0;i<n;i++)
    {
        if(s&(1<<i))
        {
            B[1][i+1]=1;
            if(A[1][i+1]==0)
                cnt++;
        }
        else if(A[1][i+1]==1)
            return inf;
    }
    int sum=0;
    for(i=2;i<=n;i++)
        for(j=1;j<=n;j++)
    {
        sum=0;
        sum+=B[i-2][j]+B[i-1][j-1]+B[i-1][j+1];
        B[i][j]=sum%2;
        if(B[i][j]==0&&A[i][j]==1)
            return inf;
        if(B[i][j]!=A[i][j])
            cnt++;
    }
    return cnt;
}
int main()
{
    int i,ans,j,cas,t;
    scanf("%d",&t);
    for(cas=1;cas<=t;cas++)
    {
        scanf("%d",&n);
        ans=inf;
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            scanf("%d",&A[i][j]);
        for(i=0;i<(1<<n);i++)
        {
            ans=min(ans,solve(i));
        }
        if(ans==inf)
            printf("Case %d: -1\n",cas);
        else
            printf("Case %d: %d\n",cas,ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值