2014ACM/ICPC亚洲区鞍山赛区现场赛I (hdu 5078)

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 122    Accepted Submission(s): 84
Special Judge


Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.


Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time t i at place (x i, y i), and you should click it exactly at t i at (x i, y i). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between t i and t i+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, t i(0 ≤ t i < t i+1 ≤ 10 6), x i, and y i (0 ≤ x i, y i ≤ 10 6) as mentioned above.
 

Output
For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
  
  
2 5 2 1 9 3 7 2 5 9 0 6 6 3 7 6 0 10 11 35 67 23 2 29 29 58 22 30 67 69 36 56 93 62 42 11 67 73 29 68 19 21 72 37 84 82 24 98
 

Sample Output
  
  
9.2195444573 54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.

题意:给你n个要做的动作,每个动作有两个属性,分别是时间,和坐标,然后做完一个动作的难度是(两个点的距离)/(两个点的时间差),让我们求最大难度的动作难度是多少?

解法:水题。主要注意要用__int64,直接进行(n-1)次比较就好了,取出最大值就ok。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL  long long
#define inf 0x0f0f0f0f
#define maxn 4
using namespace std;
struct number
{
    int t;
    __int64 x;
    __int64 y;
}num[1005];
bool cmp(struct number a,struct number b)
{
    return a.t<b.t;
}
int main()
{
    int t;
    int n;
    double ans;
    double tt;
    int i;
    scanf("%d",&t);
    while(t--)
    {
        ans=-10000;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d%I64d%I64d",&num[i].t,&num[i].x,&num[i].y);
        sort(num,num+n,cmp);
        for(i=1;i<n;i++)
        {
            tt=(num[i].x-num[i-1].x)*(num[i].x-num[i-1].x);
            tt+=(num[i].y-num[i-1].y)*(num[i].y-num[i-1].y);
            tt=sqrt(tt);
            tt=tt/(num[i].t-num[i-1].t);
            if(tt>ans)
                ans=tt;
        }
        printf("%.10f\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值