PAT甲级1008. Elevator (20)

8 篇文章 0 订阅
求电梯运行的总时间

简单不解释
题目在这里

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41


代码奉上
#include <iostream>
#define UP 6 //为了代码思路清晰,用宏分别定义上一楼,下一楼,停一楼的时间
#define DOWN 4
#define STAY 5

using namespace std;

int main(void)
{
    int N = 0;//记录进行需要的次数
    int sum = 0;//总时间
    int start = 0;//开始楼层即0层
    int next = 0;//下一个去哪?

    cin >> N;//输入总次数

    for (int i = 0; i < N; ++i)
    {
        cin >> next;//输入下一个楼层

        if (next > start)//如果要上楼
        {
            sum += (next - start) * UP;
        }
        else//下楼
        {
            sum += (start - next) * DOWN;
        }

        start = next;//将next设为下一个的start
    }
    sum += N * STAY;//加上总停留时间

    //输出
    cout << sum << endl;

    return 0;
}

好好学习,天天向上

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值