You have a maze with obstacles and non-zero digits in it

You can start from any square, walk in the maze, and finally stop at some square. Each step, you may only walk into one of the four neighbouring squares (up, down, left, right) and you cannot walk into obstacles or walk into a square more than once. When you finish, you can get a number by writing down the digits you encounter in the same order as you meet them. For example, you can get numbers 9784, 4832145 etc. The biggest number you can get is 791452384, shown in the picture above.

 

Your task is to find the biggest number you can get.

 

输入

 There will be at most 25 test cases. Each test begins with two integers R and C (2<=R,C<=15,R*C<=30), the number of rows and columns of the maze. The next R rows represent the maze. Each line contains exactly C characters (without leading or trailing spaces), each of them will be either '#' or one of the nine non-zero digits. There will be at least one non-obstacle squares (i.e. squares with a non-zero digit in it) in the maze. The input is terminated by a test case with R=C=0, you should not process it.

 

输出

 For each test case, print the biggest number you can find, on a single line.

样例输入
3 7
##9784#
##123##
##45###
0 0
样例输出
791452384
提示
来源
湖南省第六届大学生计算机程序设计竞赛


我写的代码:
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
struct move
{
	int x;
	int y;
};

int row;
int column;
char ss[15][15]={0};

move x[30];
char maxs[30]={0};

void output(int n)
{
	static int Max=0;
	char mmax[30]={0};
	int i;
	if(n>=Max)
	{
		Max=n;
		for(i=0;i<n;i++)
	    mmax[i]=ss[x[i].x][x[i].y];
	    if(strlen(maxs)<strlen(mmax))
	       strcpy(maxs,mmax);
	    if(strcmp(mmax,maxs)>0)
	    {
	    	strcpy(maxs,mmax);
	   	}
	}
}

bool fun(int i,int j,int t)//判断当前坐标是否可以继续 
{
	int f;
	if(ss[i][j]=='#') return false;
	if(i<0||i>row-1||j<0||j>column-1) return false;
	//查看之前是否走过这里
	for(f=0;f<t;f++)
	if(x[f].x==i&&x[f].y==j) return false;
	
	return true;
}

void backtrack(int i,int j,int t)
{
     //如果 上下左右 都走不通了
	if(fun(i,j,t)) 
	{
		x[t].x=i;
		x[t].y=j;
		//向上
		backtrack(i,j-1,t+1);
		
		//向下 
		backtrack(i,j+1,t+1);
		
		//向左 
		backtrack(i-1,j,t+1);
		
		//向右 
		backtrack(i+1,j,t+1);
	}
	else
	{
		if(t>0) output(t);
	}
	
	
}

int main()
{
	char getsMax[25][30]={0};
	int i,j,n=0;
	cin>>row>>column;
	while(row>0&&row>=2&&column<=15&&column>0&&row*column<=30)
	{
		    for(i=0;i<row;i++)
	        for(j=0;j<column;j++)
	        {
		       cin>>ss[i][j];
	        }
		 	
	       for(i=0;i<row;i++)
	       for(j=0;j<column;j++)
	       {
		     backtrack(i,j,0);
	       }
		 
		  // puts(maxs);
	       strcpy(getsMax[n],maxs);
		   n++;
		   cin>>row>>column;
	}

	for(i=0;i<n;i++)
		cout<<getsMax[i]<<endl;
	return 0;
} 




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值