UVA 591 (13.08.06)

 Box of Bricks 

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and buildsstacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you shouldmake all stacks the same height. Then you would have a real wall.'', she retorts. After a little con-sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that allstacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimumnumber of bricks moved. Can you help?

Input 

The input consists of several data sets. Each set begins with a line containing the number n of stacksBob has built. The next line contains n numbers, the heights h i of the n stacks. You may assume $1 Ÿ\le n \leŸ 50$and $1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possibleto rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line`` The minimum number of moves is k.'', where k is the minimum number of bricks thathave to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.




题意与做法: (大水题)

转箱子, 直到各堆的箱子数一样

因为一次只能转一个箱子, 所以求出平均数, 然后大于平均数的累加起来即可~

不会出现奇葩数据, 例如平均数不是个整数等等


AC代码:

#include<stdio.h>

int main() {
    int box[100];
    int n, sum, aver, ans;
    int cas = 0;
    while(scanf("%d", &n) != EOF) {
        if(n == 0)
            break;
        sum = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d", &box[i]);
            sum += box[i];
        }
        aver = sum / n;
        ans = 0;
        for(int i = 0; i < n; i++) 
            if(box[i] > aver)
                ans += (box[i] - aver);
        printf("Set #%d\n", ++cas);
        printf("The minimum number of moves is %d.\n", ans);
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值