HDOJ 1160 FatMouse's Speed (结构体排序+动态规划)详解

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1460 Accepted Submission(s): 730

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output

            Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900
 

Sample Output
4
4
5
9
7
 


Source
Zhejiang University Training Contest 2001
 

Recommend
Ignatius

这道题和求解最长单调子序列  Super Jumping! Jumping! Jumping!其实是一样的思路
只不过多了排序。
题意就是:找尽量多的满足   体重越大   速度越慢   的例子。
(居然1A了,做梦一样)
#include<iostream>
#include<string>
#include<cstring>  
#include<cmath>  
#include<algorithm>  
using namespace std;
#define max_n 1010

int dp[max_n] = {0};
int pos[max_n] = { 0 };//寻找位置  
struct mouse
{
	int weight;
	int speed;
	int num;//表示位置
}mice[max_n];

bool cmp(mouse a, mouse b)//重量按照从小到大  速度从大到小
{
	if (a.weight == b.weight)return a.speed > b.speed;
	return a.weight < b.weight;
}

int main()
{
	int i = 1;
	int ans = 0;
	while (cin>>mice[i-1].weight>>mice[i-1].speed)
	{
		mice[i-1].num =i;
		i++;
	}
	i--;//因为i多加了1
	sort(mice, mice + i, cmp);
	for (int j = 1; j < i; j++)//这个就是按照速度的递减子序列  dp数组里存的是子序列的长度
	{
		for (int k = 0; k < i; k++)
		{
			if (mice[j].weight > mice[k].weight&&mice[j].speed < mice[k].speed)dp[j] = max(dp[j], dp[k] + 1);
			if (dp[j] > ans)ans = dp[j];
		}
	}
	int p = 0;
	int t = ans;
	mouse temp;
	for (int j = i - 1; j >= 0 && t >= 0; j--)//找到选择的老鼠的位置  t要>=0是为了找到起始位置
	{
		if (dp[j] == t&&t == ans) //第一次只要找到最后一个长度最长的老鼠就可以了
		{	t--;
		pos[p++] = j;
		temp.weight = mice[j].weight;
		temp.speed = mice[j].speed;
		continue;
		}
		if (dp[j] == t&&mice[j].weight<temp.weight&&mice[j].speed>temp.speed)//后面的只要满足这个条件就可以选进来
		{
			t--;
			pos[p++] = j;
			temp.weight = mice[j].weight;
			temp.speed = mice[j].speed;
		}

	}
	cout << ans +1<< endl;//dp里的长度没有包括起始位置
	p--;//p多加了1
	while (p>=0)//因为是倒序存在pos里的
	{
		cout << mice[pos[p--]].num << endl;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值