HDOJ 1016 Prime Ring Problem (DFS)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 719 Accepted Submission(s): 431
 
Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 
Input
n (0 < n < 20).
 
Output

            The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 
Sample Input
6
8
 
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
 
Source
Asia 1996, Shanghai (Mainland China)
 
Recommend
JGShining
 

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<cmath>  
using namespace std;

int n;
int prime[400] = {0};
int v[25];
int ans[25];


void inite()//素数打表
{
	for (int i = 2; i < 200; i++)
	{
		if (prime[i] == 0)
		{
			for (int j = 2; i*j < 400; j++)
			{
				prime[i*j] = 1;
			}
		}
	}


}
void dfs(int index,int deep)//值 和深度
{
	v[index] = 1;
	ans[deep] = index;
	if (deep == n - 1 && prime[ans[deep] + 1] == 0)//满足素数环输出
	{
		for (int i = 0; i < n-1; i++)//因为满足条件的结果很多,所以要一边找一边输出
		{
			cout << ans[i]<<" ";
		}
		cout <<ans[n-1]<<endl;
	}
	for (int i = 2; i <= n; i++)
	{
		if (v[i] == 0 && prime[i + ans[deep]] == 0)//符合条件
		{
			dfs(i, deep + 1);
		}
	}
	v[index] = 0;//取消标记
}


int main()
{
	int cnt = 0;
	inite();
	while (cin>>n)//有的会找不到
	{
		memset(v, 0, sizeof(v));
		memset(ans, 0, sizeof(ans));
		cnt++;
		cout << "Case "<<cnt<<":" << endl;
		dfs(1, 0);
		cout << endl;
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值