Let S be a sequence of integers s1, s2, ..., sn Each integer is is associated with a weight by the following rules:
(1) If is is negative, then its weight is 0.
(2) If is is greater than or equal to 10000, then its weight is 5. Furthermore, the real integer value of si is si−10000 . For example, if si is 10101, then is is reset to 101 and its weight is 5.
(3) Otherwise, its weight is 1.
A non-decreasing subsequence of S is a subsequence si1, si2, ..., sik, with i1<i2 ... <ik, such that, for all 1≤j<k, we have sij<sij+1.
A heaviest non-decreasing subsequence of S is a non-decreasing subsequence with the maximum sum of weights.
Write a program that reads a sequence of integers, and outputs the weight of its
heaviest non-decreasing subsequence. For example, given the following sequence:
80 75 73 93 73 73 10101 97 −1 −1 114 −1 10113 118
The heaviest non-decreasing subsequence of the sequence is <73,73,73,101,113,118> with the total weight being 1+1+1+5+5+1=14. Therefore, your program should output 14 in this example.
We guarantee that the length of the sequence does not exceed 2∗105
Input Format
A list of integers separated by blanks:s1, s2,...,sn
Output Format
A positive integer that is the weight of the heaviest non-decreasing subsequence.
样例输入
80 75 73 93 73 73 10101 97 -1 -1 114 -1 10113 118
样例输出
14
#include <cstdio>
#include<cstring>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 22222;
int MAX[maxn << 2];
void PushUP(int rt) {
MAX[rt] = max(MAX[rt << 1], MAX[rt << 1 | 1]);
}
void update(int p, int w,int l, int r, int rt) {
if (l == r) {
MAX[rt]=max(w,MAX[rt]);//dp方程:dp[i]=max(dp[i],dp[j]+w)
return;
}
int m = (l + r) >> 1;
if (p <= m) update(p,w, lson);
else update(p,w, rson);
PushUP(rt);
}
int query(int L, int R, int l, int r, int rt) {
if (L <= l && r <= R) {
return MAX[rt];
}
int m = (l + r) >> 1;
int ret = 0;
if (L <= m) ret = max(ret, query(L, R, lson));
if (R > m) ret = max(ret, query(L, R, rson));
return ret;
}
int main() {
memset(MAX, 0, sizeof(MAX));
int n, w;
while (scanf("%d", &n) != EOF)
{
if (n < 0) continue;
else if (n >= 10000)
{
w = 5;
n -= 10000;
}
else w = 1;
update(n, query(1,n,1,10001,1) + w,1,10001,1);//在n出现之前,值比n小的,最大权值
}
printf("%d\n", query(1,10001,1,10001,1));
return 0;
}