hdu1542 Atlantis(扫描线+矩形面积并)

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14664    Accepted Submission(s): 6045


Problem Description
There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
 

Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
 

Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
 

Sample Input
  
  
2 10 10 20 20 15 15 25 25.5 0
 

Sample Output
  
  
Test case #1 Total explored area: 180.00
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1828  1255  1166  1823  3016 
 


思路:浮点数先要离散化;然后把矩形分成两条边,上边和下边,对横轴建树,然后从下到上扫描上去,用cnt表示该区间下边比上边多几个

线段树操作:update:区间增减 query:直接取根节点的值

#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1


const int maxn = 2222;
int cnt[maxn << 2];//边重复的次数
double sum[maxn << 2];
double X[maxn];
struct Seg {
	double h, l, r;
	int s;//1为入边,-1为出边
	Seg() {}
	Seg(double a, double b, double c, int d) : l(a), r(b), h(c), s(d) {}
	bool operator < (const Seg &cmp) const {
		return h < cmp.h;
	}
}ss[maxn];
void PushUp(int rt, int l, int r) {
	//每个区间求[l, r-1],算的时候右边加一,这样递归的时候就不用考虑叶子节点了。
	if (cnt[rt]) sum[rt] = X[r + 1] - X[l];//这条边存在
	else if (l == r) sum[rt] = 0;//边不存在,又是叶子节点
	else sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void update(int L, int R, int c, int l, int r, int rt) {
	if (L <= l && r <= R) {
		cnt[rt] += c;
		PushUp(rt, l, r);
		return;
	}
	int m = (l + r) >> 1;
	if (L <= m) update(L, R, c, lson);
	if (m < R) update(L, R, c, rson);
	PushUp(rt, l, r);
}
int main() {
	int n, cas = 1;
	while (~scanf("%d", &n) && n) {
		int m = 0;
		while (n--) {
			double a, b, c, d;
			scanf("%lf%lf%lf%lf", &a, &b, &c, &d);
			X[m] = a;
			ss[m++] = Seg(a, c, b, 1);
			X[m] = c;
			ss[m++] = Seg(a, c, d, -1);
		}
		//离散化
		sort(X, X + m);
		sort(ss, ss + m);
		int k = unique(X, X + m) - X;
		memset(cnt, 0, sizeof(cnt));
		memset(sum, 0, sizeof(sum));
		double ret = 0;
		for (int i = 0; i < m - 1; i++) {
			int l = lower_bound(X, X + k, ss[i].l) - X;
			int r = lower_bound(X, X + k, ss[i].r) - X - 1;
			if (l <= r) update(l, r, ss[i].s, 0, k - 1, 1);
			ret += sum[1] * (ss[i + 1].h - ss[i].h);//sum[1]代表x轴的长度和
		}
		printf("Test case #%d\nTotal explored area: %.2lf\n\n", cas++, ret);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值