poj 3855 Blast the Enemy! (计算几何)

D - Blast the Enemy!
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

A new computer game has just arrived and as an active and always-in-the-scene player, you should finish it before the next university term starts. At each stage of this game, you have to shoot an enemy robot on its weakness point. The weakness point of a robot is always the “center of mass” of its 2D shape in the screen. Fortunately, all robot shapes are simple polygons with uniform density and you can write programs to calculate exactly the center of mass for each polygon. 

Let's have a more formal definition for center of mass (COM). The center of mass for a square, (also circle, and other symmetric shapes) is its center point. And, if a simple shape C is partitioned into two simple shapes A and B with areas SA and SB, then COM(C) (as a vector) can be calculated by 



As a more formal definition, for a simple shape A with area SA: 

Input

The input contains a number of robot definitions. Each robot definition starts with a line containing n, the number of vertices in robot’s polygon (n <= 100). The polygon vertices are specified in the next n lines (in either clockwise or counter-clock-wise order). Each of these lines contains two space-separated integers showing the coordinates of the corresponding vertex. The absolute value of the coordinates does not exceed 100. The case of n=0 shows the end of input and should not be processed.

Output

The ith line of the output should be of the form “Stage #i: x y” (omit the quotes), where (x,y) is the center of massfor the ith robot in the input. The coordinates must be rounded to exactly 6 digits after the decimal point.

Sample Input

4
0 0
0 1
1 1
1 0
3
0 1
1 0
2 2
8
1 1
2 1
2 7
3 7
3 0
0 0
0 7
1 7
0

Sample Output

Stage #1: 0.500000 0.500000
Stage #2: 1.000000 1.000000
Stage #3: 1.500000 3.300000

思路: 

求n边形的质心,赤果果的模板题。


#include <cstdio>
#include <cstring>
#include <cmath>
const long M=110;
struct Point{
	double x,y;
	Point(double x=0.0,double y=0.0):x(x),y(y){}
}p[M];
double Mult(Point P1,Point P2){
	return P1.x*P2.y-P1.y*P2.x;
}

long n;
Point get_ans(){
	Point com;
	double area=0;
	for (long i=1;i<n;++i){
		double mult=Mult(p[i],p[i+1]);
		area+=mult;
		com.x+=(p[i].x+p[i+1].x)/3*mult;
		com.y+=(p[i].y+p[i+1].y)/3*mult;
	}
	double mult=Mult(p[n],p[1]);
	area+=mult;
	com.x+=(p[n].x+p[1].x)/3*mult;
	com.y+=(p[n].y+p[1].y)/3*mult;
	com.x/=area; com.y/=area;
	return com;
}
int main(){
	long cnt=0;
	while (~scanf("%d",&n) && n){
		for (long i=1;i<=n;++i)
			scanf("%lf%lf",&p[i].x,&p[i].y);
		Point ans=get_ans();
		printf("Stage #%d: %.6f %.6f\n",++cnt,ans.x,ans.y);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值