1002:解一元二次方程ax^2+bx+c=0的解。

/** 安徽科技学院acm题

*/

Input 

a,b,c的值。

Output

两个根x1和x2,其中x1>=x2。。结果保留两位小数

Sample Input

1 5 -2

Sample Output

0.37 -5.37

代码:

import java.util.Scanner;
 
public class Main {
     public static void main(String[] args) {
         Scanner cin = new Scanner(System.in);
         int a = cin.nextInt();
         int b = cin.nextInt();
         int c = cin.nextInt();
         double x1 = (-b + Math.sqrt(b * b - 4 * a * c)) / (2 * a);
         double x2 = (-b - Math.sqrt(b * b - 4 * a * c)) / (2 * a);
         if (x1 > x2)
             System.out.printf("%.2f %.2f",x1,x2);
         else
             System.out.printf("%.2f %.2f",x2,x1);
     }
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值