1175: ACM"水题"

题目

Description

ACM中把一种题称作“水题”,顾名思义就是题目很水,很简单。为了促进提高大伙的编程兴趣,
zjahstu决定贯彻“没有最水,只有更水”的原则。

现在给定两个数a和b, 计算[a,b]之间整数的和。(当a=b=0时候表示输入结束,不必处理)
Input

1 100
1 10
99 100
0 0
Output

5050
55
199

Sample Input

1 100
1 10
99 100
0 0
Sample Output

5050
55
199


代码块

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        while(cn.hasNext()){
            int a = cn.nextInt();
            int b = cn.nextInt();
            if(a==0&&b==0) break;
            System.out.println(Sum(a,b));
        }
    }

    private static int Sum(int a, int b) {
        int sum = 0;
        for(int i =a;i<=b;i++){
            sum+=i;
        }
        return sum;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值