1262: 判断奇偶性

题目

Description

计算一个无符号整数x中位的个数是奇数还是偶数。

Input

多组测试数据。每组测试数据包括一个无符号整数n(0<n<2^32-1)

Output

若包含偶数个1,则输出even,否则输出odd。

Sample Input

8
7
6
15
4294967294
4294967295
Sample Output

odd
odd
even
even
odd
even

代码块

因为题目中的测试数比较大,因此我用的是bigInteger类,如果想要优化一点,可以在int范围内的时候用普通的处理方法,用if判断一下,大的数再用bigInteger


import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        while(cn.hasNext()){
            String str = cn.next();
            BigInteger big = new BigInteger(str);
            int count =0;
            while(big.compareTo(new BigInteger(Integer.toString(0)))==1){
                BigInteger big1 = big;
                BigInteger t = new BigInteger(Integer.toString(2));
                big = big.divide(t);
                if(big.multiply(t).compareTo(big1)!=0){
                    count++;
                }
            }
            if(count%2==0) System.out.println("even");
            else System.out.println("odd");
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值