poj 2431 Expedition

链接:  http://poj.org/problem?id=2431 


Language:
Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4423 Accepted: 1411

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source




贪心,先用现有的油往前走,油不够时,在已经走过的站中,找能供油量最大的加油,如果还不够找第二大供油的站......,这里可以用优先队列来存



注意最后一站的处理



#include<iostream>
#include<queue>
#define maxn 1000000+5
struct stops
{
	int oil,dis;
}stop[maxn];
bool cmp(stops a,stops b)
{
	return a.dis<b.dis;
}
using namespace std;
int main()
{
	priority_queue <int> q;
	int n,p,l;
	while(scanf("%d",&n)!=EOF)
	{
		int a,box,cur,next,sum,time;
		for(a=n-1;a>=0;a--) scanf("%d%d",&stop[a].dis,&stop[a].oil);
		scanf("%d%d",&l,&p);
		for(a=n-1;a>=0;a--) stop[a].dis=l-stop[a].dis;//把距离改为从起点到该站的距离
		sort(stop,stop+n,cmp);//惯性思维,以为输入是默认从小到大的,i remeber you!
		time=cur=0,sum=box=p;
		for(a=0;a<n;a++)
		{
			next=stop[a].dis-cur;//现在的位置到下一站的距离
			while(box<next)//如果油不够用
			{
				if(!q.empty())
				{
					sum=sum+q.top();
					box=box+q.top();//加油
					q.pop();
					time++;
				}
				else break;
			}
			if(box<next) {sum=-1;break;}
			box=box-next;
			cur=stop[a].dis;
			q.push(stop[a].oil);//记录下加油量
		}
		if(!q.empty()&&sum!=-1&&sum<l) {sum=sum+q.top();time++;}//因为是先能到达再加油,所以第n站只能加前n-1站的油,所以最后1站的加不到
		if(sum>=l)
		printf("%d\n",time);
		else printf("-1\n");
		while(!q.empty()) q.pop();
	}
	return 0;
}


1.问题描述 给定一个N*N 的方形网格,设其左上角为起点,坐标为(1,1),X 轴向右为正,Y 轴 向下为正,每个方格边长为1。一辆汽车从起点出发驶向右下角终点,其坐标为(N,N)。 在若干个网格交叉点处,设置了油库,可供汽车在行驶途中加油。汽车在行驶过程中应遵守 如下规则: (1)汽车只能沿网格边行驶,装满油后能行驶K 条网格边。出发时汽车已装满油,在 起点与终点处不设油库。 (2)当汽车行驶经过一条网格边时,若其X 坐标或Y 坐标减小,则应付费用B,否则 免付费用。 (3)汽车在行驶过程中遇油库则应加满油并付加油费用A。 (4)在需要时可在网格点处增设油库,并付增设油库费用C(不含加油费用A)。 (5)(1)~(4)中的各数N、K、A、B、C均为正整数。 算法设计: 求汽车从起点出发到达终点的一条所付费用最少的行驶路线。 数据输入: 输入数据。第一行是N,K,A,B,C的值,2 <= N <= 100, 2 <= K <= 10。第二行起是一个N*N 的0-1方阵,每行N 个值,至N+1行结束。方阵的第i 行第j 列处的值为1 表示在网格交叉点(i,j)处设置了一个油库,为0 时表示未设油库。 各行相邻的2 个数以空格分隔。 结果输出: 将找到的最优行驶路线所需的费用,即最小费用输出. Sample input 9 3 2 3 6 0 0 0 0 1 0 0 0 0 0 0 0 1 0 1 1 0 0 1 0 1 0 0 0 0 1 0 0 0 0 0 0 1 0 0 1 1 0 0 1 0 0 1 0 0 0 1 0 0 0 0 0 1 0 0 0 0 0 1 0 0 0 1 1 0 0 1 0 0 0 1 0 0 1 0 0 0 0 0 0 0 Sample output 12
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值