Babs’ Box Boutique DFS()

http://acm.sdut.edu.cn/sdutoj/showproblem.php?pid=1943&cid=1144

 

Babs’ Box Boutique

Time Limit: 1000MS    Memory limit: 65536K

题目描述

Babs sells boxes and lots of them. All her boxes are rectangular but come in many different sizes. Babs wants to create a really eye-catching display by stacking, one on top of another, as many boxes as she can outside her store. To maintain neatness and stability, she will always have the sides of the boxes parallel but will never put a box on top of another if the top box sticks out over the bottom one. For example, a box with base 5-by-10 can not be placed on a box with base 12-by-4.
Of course the boxes have three dimensions and Babs can orient the boxes anyway she wishes. Thus a
5-by-10-by-12 box may be stacked so the base is 5-by-10, 5-by-12, or 10-by-12.
For example, if Babs currently has 4 boxes of dimensions 2-2-9, 6-5-5, 1-4-9, and 3-1-1, she could stack up to 3 boxes but not all four. (For example, the third box, the first box, then the last box, appropriately oriented. Alternatively, the second box could replace the third (bottom) box.)
Babs’ stock rotates, so the boxes she stacks outside change frequently. It’s just too much for Babs to figure out and so she has come to you for help. Your job is to find the most boxes Babs can stack up
given her current inventory. Babs will have no more than 10 different sized boxes and will use at most one box of any size in her display.

输入

A positive integer n (n ≤ 10) will be on the first input line for each test case. Each of the next n lines will contain three positive integers giving the dimensions of a box. No two boxes will have identical dimensions. None of the dimensions will exceed 20. A line with 0 will follow the last test case.

输出

For each test case, output the maximum number of boxes Babs can stack using the format given below.

示例输入

4
2 2 9
6 5 5
1 4 9
3 1 1
3
2 4 2
1 5 2
3 4 1
0

示例输出

Case 1: 3
Case 2: 3
 
 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
using namespace std;
struct node
{
    int a;
    int b;
    int c;
} p[1001];
int n;
int Max;
int visit[1001];
void DFS(int ax,int ay,int k,int t)
{
   // printf("%d %d %d %d\n",ax,ay,k,t);
    if(t>Max)
    {
        Max=t;
    }
        for(int i=0; i<n; i++)
        {
            if(visit[i]==0)
            {
                if(p[i].a>=ax&&p[i].b>=ay)
                {
                    visit[i]=1;
                    DFS(p[i].a,p[i].b,k+1,t+1);
                    visit[i]=0;
                }
                else if(p[i].a>=ax&&p[i].c>=ay)
                {
                    visit[i]=1;
                    DFS(p[i].a,p[i].c,k+1,t+1);
                    visit[i]=0;
                }
                else  if(p[i].b>=ax&&p[i].c>=ay)
                {
                    visit[i]=1;
                    DFS(p[i].b,p[i].c,k+1,t+1);
                    visit[i]=0;
                }
            }
        }
}
int main()
{
    int kk=1;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)  break;
        memset(visit,0,sizeof(visit));
        int aa,bb,cc;
        int t[4];
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<3; j++)
                scanf("%d",&t[j]);
            sort(t,t+3);
            p[i].a=t[0] ;
            p[i].b=t[1];
            p[i].c=t[2];
        }
       // for(int i=0;i<n;i++)
       // printf("%d %d %d\n",p[i].a,p[i].b,p[i].c);
        Max=0;
        DFS(0,0,0,0);
        printf("Case %d: %d\n",kk,Max);
        kk++;
    }
    return 0;
}
/*
6
1 2 3
4 5 6
1 2 4
3 2 1
1 1 1
2 3 1
*/
在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值