杭电acm:大数阶乘(附源码)

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3

Sample Output

 1
 2
 6
#include <stdio.h>
int main()
{
    int tmp,n,j;
    int a[35661];//10000的阶乘位数为35660
    int d;
    int temp,i;   
    while(scanf("%d",&n)!=EOF){
    a[0]=1;d=1;
    for(i=2; i<=n; i++)
    {
        for(tmp=0,j=1; j<=d; ++j)//大于十进位
        {
            temp=a[j-1]*i+tmp;
            a[j-1]=temp%10;
            tmp=temp/10;
        }
        while(tmp)
        {
            a[++d-1]=tmp%10;
            tmp/=10;
        }
    }
   
    for(int k=d; k>=1; --k)//去掉多余的0
        printf("%d",a[k-1]);
    printf("\n");
 }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值