poj 2531 Network Saboteur(DFS,题意)

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

30 50 3050 0 4030 40 0

Sample Output

90
本题的重点是读懂题意(大致意思就是给你一个集合,让你把这个集合分为两个集合,求该集合使得:A集合中的每个元素到B集合中的每个元素之和最大) ,刚开始用dfs,里面了两个for循环就超时了。后来发现有简便的算法,将一个新的数b添加进去,总的和的改变就是减少了原来A集合的每个数到b的距离,增加了b到B中其余元素的距离,而A中的数是vis过的,所以只需要-map[i][b](i未已问过),+map[i][b](i未访问过)即可;
下面为DFS代码(94ms):
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[22][22],vis[22],n,ans=0;
void dfs(int x,int sum)
{
    vis[x]=1;
    for(int i=0; i<n; i++)
    {
        if(vis[i])
            sum-=a[x][i];
        else
            sum+=a[x][i];
    }
    if(sum>ans)
        ans=sum;
    for(int i=x+1; i<n; i++)
    {
        dfs(i,sum);
        vis[i]=0;
    }
    return;

}
int main()
{
    scanf("%d",&n);
    memset(vis,0,sizeof(vis));
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            scanf("%d",&a[i][j]);
    dfs(0,0);
    printf("%d\n",ans);
    return 0;
}
然后,我发现,其实A集合中数的总数一直小于B也会成立,因为A,B间是双向的:
DFS2:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int a[22][22],b[22],vis[22],n,sum=0,ans=0;
void dfs(int x,int step,int sum)
{
    vis[x]=1;
    if(step==n/2+1)
        return;
    for(int i=0; i<n; i++)
    {
        if(vis[i])
            sum-=a[x][i];
        else
            sum+=a[x][i];
    }
    if(sum>ans)
        ans=sum;
    for(int i=x+1; i<n; i++)
    {
        dfs(i,step+1,sum);
        vis[i]=0;
    }
    return;
}
int main()
{
    scanf("%d",&n);
    memset(vis,0,sizeof(vis));
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            scanf("%d",&a[i][j]);
    dfs(0,0,0);
    printf("%d\n",ans);
    return 0;
}

遗憾的是,还是94ms,没有变化,期待明天的BFS:


好的吧,我尽力了,这题不知道要怎么用广搜写、、
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值