Problem H

Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.<br><br>
 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.<br>The last test case is followed by a line containing two zeros, which means the end of the input.<br>
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.<br>
 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
  
  
3 5


思路:

每输入一条边,判断此边两端点是不是在同一颗树上,如果在同一颗树上,判断树是不是有环,如果有环,则不加入此边,如果没环,加入此边(合并);

如果两棵树都没有环,直接合并即可,

如果只有一棵树有环,可以合并,并标记,

如果都有环,显然不能合并


ac代码:

#include<stdio.h>  
#include<algorithm>  
#include<string.h>  
using namespace std;  
int visit[10005];  
int set[10005];  
struct node  
{  
    int s;  
    int e;  
    int len;  
}a[100005];  
int cmp(node a,node b)  
{  
    return a.len>b.len;  
}  
int find(int x)  
{  
    int r=x;  
    while(r!=set[r])  
    r=set[r];  
    int i=x;  
    while(i!=r)  
    {  
        int j=set[i];  
        set[i]=r;  
        i=j;  
    }  
    return r;  
}  
int main()  
{  
    int n,m;  
    while(scanf("%d%d",&n,&m)!=EOF)  
    {  
        memset(a,0,sizeof(a));  
        int ans=0;  
        if(n==0&&m==0)  
        break;  
        for(int i=0;i<=n;i++)  
        {  
            set[i]=i;  
            visit[i]=0;  
        }  
        for(int i=1;i<=m;i++)  
              scanf("%d%d%d",&a[i].s,&a[i].e,&a[i].len);  
              sort(a+1,a+m+1,cmp);  
        for(int i=1;i<=m;i++)  
        {  
            int fx=find(a[i].s);  
            int fy=find(a[i].e);  
            if(fx==fy)  
            {  
                if(visit[fx]==1)  
                continue;  
                visit[fx]=1;
            }  
            else  
            {  
                if(visit[fx]==1&&visit[fy]==1)  
                continue;  
                else if(visit[fx]==0)  
                    set[fx]=fy;  
                else  
                set[fy]=fx;  
            }  
            ans+=a[i].len;  
        }  
        printf("%d\n",ans);  
    }  
    return 0;  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值