Smeech


Problem Description
Professor Octastichs has invented a new programming language, Smeech. An expression in Smeech may be a positive or negative integer, or may be of the form (p e1 e2) where p is a real number between 0 and 1 (inclusive) and e1 and e2 are Smeech expressions. The value represented by a Smeech expression is as follows:
1) An integer represents itself
2) With probability p, (p e1 e2) represents x+y where x is the value of e1 and y is the value of e2; otherwise it represents x-y.
Given a Smeech expression, what is its expected value?
 

Input
Input consists of several Smeech expressions, one per line, followed by a line containing ().
 

Output
For each expression, output its expected value to two decimal places.
 

Sample Input
  
  
7 (.5 3 9) ()
 

Sample Output
  
  
7.00 3.00
 

Author
Gordon V. Cormack
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1904  1903  1908  1914  1913 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

double func(char *c)
{
    double d;
    sscanf(c,"%lf",&d);
    return d;
}
double T(char *b)
{ int t=1;int n=0;
    double p,x,y;
        if(b[t]!='(')
        {
            p=func(b+t);
            while(b[t]!=' '&&b[t]!=')'&&b[t]!='(')
            {
                t++;
            }
        }
        if(b[t]=='(')
         {

        p=T(b+t);
        t++;
        while(n+1)
        {
            if(b[t]=='(')
                n++;
            if(b[t]==')')
                n--;
            t++;
        }
        }
        n=0;
        if(b[t]==' ')
            t++;
        if(b[t]!='(')
        {
            x=func(b+t);
        while(b[t]!=' '&&b[t]!=')'&&b[t]!='(')
            {
                t++;
            }
        }
        if(b[t]=='(')
        {
            x=T(b+t);
            t++;
            while(n+1)
            {
                if(b[t]=='(')
                    n++;
                if(b[t]==')')
                    n--;
                t++;
            }
        }
        n=0;
        if(b[t]==' ')
            t++;
        if(b[t]!='(')
        {
            y=func(b+t);
        while(b[t]!=' '&&b[t]!=')'&&b[t]!='(')
            {
                t++;
            }
            }
        if(b[t]=='(')
           {
            y=T(b+t);

        t++;
        while(n+1)
        {
            if(b[t]=='(')
                n++;
            if(b[t]==')')
                n--;
            t++;
        }
        }
        n=0;
       return (x+y)*p+(x-y)*(1-p);
}
int main()
{
    double a;char b[99999];

    while(gets(b))
    {
        if(b[0]!='(')
        {
            sscanf(b,"%lf",&a);
            printf("%0.2lf\n",a);
        }
        if(b[0]=='('&&b[1]==')')
           break;
        else if(b[0]=='(')
            printf("%0.2lf\n",T(b));
    }
        return 0;
}


/*#include<stdio.h>

#include<string.h>

#include<math.h>

char s[1248];

double Getanswer(char *s)

{

  double ans,p,x,y;

  int i,j,n;
  if(s[0]!='(')//输入的就是一个数字

  {

sscanf(s,"%lf",&ans);//字符串转换为double

    return ans;

  }

  sscanf(s+1,"%lf",&p);

  i=0;

  while(s[i++]!=' ');       //while(s[i]!=' ')    {  i++;   }

  if(s[i]!='(')

  {

    sscanf(s+i,"%lf",&x);

    while(s[i++]!=' ');

if(s[i]!='(')   sscanf(s+i,"%lf",&y);

    else             y=Getanswer(s+i);

  }

  else

  {

     n=1;

     for(j=i+1;n;j++)//左右括号的析取抵消

      {
        if(s[j]=='(')   ++n;

        if(s[j]==')')     --n;

      }

      s[j]='\0';

      x=Getanswer(s+i);

      if(s[j+1]=='(')    y=Getanswer(s+j+1);

      else              sscanf(s+j+1,"%lf",&y);

  }

  return x+(p+p-1)*y;

}

int main()

{

   while(gets(s))

    {

     if(strcmp(s,"()")==0)     break;

      printf("%.2lf\n",Getanswer(s));

    }

}
*/
/*
#include<iostream>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<cstring>
#include<string>
#include<algorithm>
#define min 1e-6
using namespace std;
char s[100000];
int FLAG;
double func1(char c)
{
    char str[100000];
    str[0]=c;
    int flag=1;
    while(str[flag++]=s[FLAG++])
        if(str[flag-1]==' '||str[flag-1]=='\n'||str[flag-1]==')')
            break;
    str[flag-1]='\0';
    double re;
    sscanf(str,"%lf",&re);
    return re;
}
double func2()
{
    double a[3];
    FLAG++;
    for(int i=0; i<3; i++)
        if(s[FLAG]!=0)
            if(s[FLAG]!='(')
                a[i]=func1(s[FLAG++]);
            else
                a[i]=func2();
    FLAG++;
    return (a[2]+a[1])*a[0]+(a[1]-a[2])*(1-a[0]);
}
int main()
{
    while(gets(s)&&strcmp(s,"()"))
    {
        FLAG=0;
        double x;
        if(s[0]!='(')
            sscanf(s,"%lf",&x);
        else
            x=func2();
        printf("%.2lf\n",x);
    }
    return 0;
}
*/


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
毕业设计,基于SpringBoot+Vue+MySQL开发的社区医院管理系统,源码+数据库+毕业论文+视频演示 信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的社区医院管理系统实现了病例信息、字典表、家庭医生、健康档案、就诊信息、前台、药品、用户、用户、用户表等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让社区医院管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。 关键字:社区医院管理系统;信息管理,时效性,安全性,MySql
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值