HDU - 1901——Smeech

Smeech

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 482    Accepted Submission(s): 109


Problem Description
Professor Octastichs has invented a new programming language, Smeech. An expression in Smeech may be a positive or negative integer, or may be of the form (p e1 e2) where p is a real number between 0 and 1 (inclusive) and e1 and e2 are Smeech expressions. The value represented by a Smeech expression is as follows: 
1) An integer represents itself 
2) With probability p, (p e1 e2) represents x+y where x is the value of e1 and y is the value of e2; otherwise it represents x-y. 
Given a Smeech expression, what is its expected value?
 

Input
Input consists of several Smeech expressions, one per line, followed by a line containing (). 
 

Output
For each expression, output its expected value to two decimal places. 
 

Sample Input
  
  
7 (.5 3 9) ()
 

Sample Output
  
  
7.00

3.00

卡了好长时间..

题意:已知值的表达形式有它本身和(p,e1,e2)两种,给出个值,求值的直观结果,保留两位输出。
      (其中(p,e1,e2)=(e1+e2)*p+(e1-e2)*(1-p))

   
   

   
   

   
   
#include<iostream>
#include<cmath>
#include<cstdio>
#include<map>
#include<set>
#include<cstring>
#include<string>
#include<algorithm>
#define min 1e-6
using namespace std;
char s[100000];
int FLAG;
double func1(char c)
{
    char str[100000];
    str[0]=c;
    int flag=1;
    while(str[flag++]=s[FLAG++])
        if(str[flag-1]==' '||str[flag-1]=='\n'||str[flag-1]==')')
            break;
    str[flag-1]='\0';
    double re;
    sscanf(str,"%lf",&re);
    return re;
}
double func2()
{
    double a[3];
    FLAG++;
    for(int i=0; i<3; i++)
        if(s[FLAG]!=0)
            if(s[FLAG]!='(')
                a[i]=func1(s[FLAG++]);
            else
                a[i]=func2();
    FLAG++;
    return (a[2]+a[1])*a[0]+(a[1]-a[2])*(1-a[0]);
}
int main()
{
    while(gets(s)&&strcmp(s,"()"))
    {
        FLAG=0;
        double x;
        if(s[0]!='(')
            sscanf(s,"%lf",&x);
        else
            x=func2();
        printf("%.2lf\n",x);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值