2039

三角形

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 86850    Accepted Submission(s): 28803


Problem Description
给定三条边,请你判断一下能不能组成一个三角形。
 

Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
 

Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
 

Sample Input
  
  
2 1 2 3 2 2 2
 

Sample Output
  
  
NO YES
 

Author
linle
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2033  2032  2042  2034  2035 

View Code

Problem : 2039 ( 三角形 )     Judge Status : Accepted
RunId : 20118288    Language : C    Author : 837274600
Code Render Status : Rendered By HDOJ C Code Render Version 0.01 Beta
#include<stdio.h>
#include<string.h>
#include<math.h>

int main()
{
    int n;
    scanf("%d", &n);
    {
        while (n--)
        {
            int  flag = 1;
            double a, b, c, temp1, temp2;
            scanf("%lf %lf %lf", &a, &b, &c);
            temp1 = a + b;
            temp2 = fabsl(a - b);
            if (temp1<=c || temp2>c)
                flag = 0;
            temp1 = a + c;
            temp2 = fabsl(a - c);
            if (!a && !b && !c)
                flag = 0;
            if (temp1<=b || temp2>=b)
                flag = 0;
            temp1 = c + b;
            temp2 = fabsl(c - b);
            if (temp1<=a || temp2>=a)
                flag = 0;
            if (flag)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值