【PAT乙级】链表元素分类 (优化中)

给定一个单链表,请编写程序将链表元素进行分类排列,使得所有负值元素都排在非负值元素的前面,而 [0, K] 区间内的元素都排在大于 K 的元素前面。但每一类内部元素的顺序是不能改变的。例如:给定链表为 18→7→-4→0→5→-6→10→11→-2,K 为 10,则输出应该为 -4→-6→-2→7→0→5→10→18→11。

输入格式:

每个输入包含一个测试用例。每个测试用例第 1 行给出:第 1 个结点的地址;结点总个数,即正整数N (≤10​5​​);以及正整数K (≤10​3​​)。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。

接下来有 N 行,每行格式为:

Address Data Next

其中 Address 是结点地址;Data 是该结点保存的数据,为 [−10​5​​,10​5​​] 区间内的整数;Next 是下一结点的地址。题目保证给出的链表不为空。

输出格式:

对每个测试用例,按链表从头到尾的顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

输出样例:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

CODE(提示的段错误是因为链表可能为空;最后一个测试点超时)

#include<iostream>
#include<list>
#include<unordered_map>
#include<unordered_set>
using namespace std;
struct Node
{
	int data;
	string next;
};
int main()
{
	ios::sync_with_stdio(false);
	unordered_map<string, Node>mm;
	unordered_map<int, string>out;
	unordered_set<string>ss;
	string begin_number;int nums, K;
	cin >> begin_number >> nums >> K;
	string a, c; int b;
	for (int i = 0; i < nums; i++)
	{
		cin >> a >> b >> c;
		ss.insert(a);
		Node temp = { b,c };
		mm[a] = temp;
		out[b] = a;
	}
	//新建链表
	list<Node>l;
	l.push_back(mm[begin_number]);
	while (ss.count(l.back().next)&&l.size()!=nums)
	{
		l.push_back(mm[l.back().next]);
	}
	list<Node> second;
	list<Node> part2;
	list<Node> part3;
	for (auto it = l.begin(); it !=l.end(); it++)
	{
		if (it->data < 0)
		{
			if (second.size() != 0)
			{
				second.back().next = out[it->data];		
			}
			second.push_back(*it);
		}
		else if (it->data >= 0 && it->data <= K)
		{
			if (part2.size() != 0)
			{
				part2.back().next = out[it->data];
			}
			part2.push_back(*it);
		}
		else {
				if (part3.size() != 0)
				{
					part3.back().next = out[it->data];
				}
				part3.push_back(*it);
		}			
	}
	
	second.back().next = out[part2.front().data];
	second.splice(second.end(), part2);
	second.back().next = out[part3.front().data];
	second.splice(second.end(), part3);
	second.back().next = "-1";
	for (auto it = second.begin(); it != second.end(); it++)
	{
		cout << out[it->data] << " " << it->data << " " << it->next << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值