矩阵链乘(Matrix Chain Multiplication)

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu

Status

Description

Download as PDF

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125
【分析】

       解析表达式:可以用一个栈来完成:遇到字母时入栈,遇到右括号时出栈并计算,然后结果入栈。因为输入保证合法,括号无须入栈。

简单的表达式解析可以借助栈来完成。

用C++语言编写程序,代码如下:

#include<iostream>
#include<stack>
#include<string>
using namespace std;

struct Matrix {
	int a, b;
	Matrix(int a = 0, int b = 0) : a(a), b(b) {}
} m[26];

stack<Matrix> s;

int main() {
	int n;
	cin >> n;
	for (int i = 0; i < n; i++) {
		string name;
		cin >> name;
		int k = name[0] - 'A';
		cin >> m[k].a >> m[k].b;
	}

	string expr;
	while (cin >> expr) {
		int len = expr.length();
		bool error = false;
		int ans = 0;
		for (int i = 0; i < len; i++) {
			if (isalpha(expr[i])) {
				s.push(m[expr[i] - 'A']);
			}
			else if (expr[i] == ')') {
				Matrix m2 = s.top(); s.pop();
				Matrix m1 = s.top(); s.pop();
				if (m1.b != m2.a) {
					error = true;
					break;
				}
				else {
					ans += m1.a * m1.b * m2.b;
					s.push(Matrix(m1.a, m2.b));
				}
			}
		}
		if (error)
			cout << "error" << endl;
		else
			cout << ans << endl;
	}
	return 0;
}

用java语言编写程序,代码如下:

import java.util.Scanner;
import java.util.Stack;

public class Main {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		Matrix[] m = new Matrix[26];
		int n = input.nextInt();
		for(int i = 0; i < n; i++) {
			String name = input.next();
			int k = name.charAt(0) - 'A';
			int r = input.nextInt();
			int c = input.nextInt();
			m[k] = new Matrix(r, c);
		}
		
		Stack<Matrix> s = new Stack<Matrix>();
		String expr;
		while(input.hasNext()) {
			expr = input.next();
			int len = expr.length();
			boolean error = false;
			int ans = 0;
			for(int i = 0; i < len; i++) {
				 char temp = expr.charAt(i);
				 if(temp >= 'A' && temp <= 'Z')
					 s.push(m[temp - 'A']);
				 else if(temp == ')'){
					 Matrix m2 = s.pop();
					 Matrix m1 = s.pop();
					 if(m1.c != m2.r) {
						 error = true;
						 break;
					 }
					 else {
						 ans += m1.r * m1.c * m2.c;
						 s.push(new Matrix(m1.r, m2.c));
					 }
				 }
			 }
			 if(error)
				 System.out.println("error");
			 else
				 System.out.println(ans);
		}
	}
	
	static class Matrix {
		int r, c;
		public Matrix(int r, int c) {
			this.r = r;
			this.c = c;
		}
	}
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值