由中序和后序重建二叉树

求二叉树的深度

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

输入

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

输出

输出二叉树的深度。

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

4

3

慢慢来

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
typedef struct node
{
	char data;
	node *lch,*rch;
}btree,*bt;
char post[55],ins[55];
void build(bt &T,char *ins,char *post,int n) //根据后序和中序重建二叉树
{
	if(n<=0) T=NULL;
	else
	{
		int k=strchr(ins,post[n-1])-ins;
		T=new btree;
		T->data=post[n-1];
		build(T->lch,ins,post,k);
		build(T->rch,ins+k+1,post+k,n-k-1);
	}
}
int deep(bt T)
{
	int dep=0;
	if(!T) return dep;
	int nl=deep(T->lch);
	int nr=deep(T->rch);
	return (nl>nr?nl:nr)+1;
}
int main()
{
	bt root;
	int n;
	cin>>n;
	getchar();
	while(n--)
	{
		cin>>ins>>post;
		build(root,ins,post,strlen(ins));
		cout<<deep(root)<<endl;
	}
	return 0;
}


 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值