POJ-Power Strings(next数组应用)

Power Strings

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

输入

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

输出

For each s you should print the largest n such that s = a^n for some string a.

示例输入

abcd
aaaa
ababab
.

示例输出

1
4
3

提示

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
 
 

给定一个字符串,问最多是多少个相同子串不重叠连接构成。

KMP的next数组应用。这里主要是如何判断是否有这样的子串,和子串的个数。

若为abababa,显然除其本身外,没有子串满足条件。而分析其next数组,next[7] = 5,next[5] = 3,next[3] = 1,即str[2..7]可由ba子串连接构成,那怎么否定这样的情况呢?很简单,若该子串满足条件,则len%sublen必为0(7%(7-5)!=0,所以不满足)。sunlen可由上面的分析得到为len-next[len]。

因为子串是首尾相接,len/sublen即为substr的个数。

若L%(L-next[L])==0,n = L/(L-next[L]),else n = 1

#include <iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <cctype>
#include <cmath>
#include <string>
using  namespace std;
char t[1000002];
int next[1000002];
void get_next(char *t,int *next)
{
  int i=0,j=-1,len=strlen(t);
  next[0]=-1;
  while(i<len)
  {
    if(j==-1||t[i]==t[j])
    {
      ++i;++j;
      if(t[i]!=t[j])
        next[i]=j;
      else
        next[i]=next[j];
    }
    else
    j=next[j];
  }
}
int main()
{
  //ios::sync_with_stdio(false);
  while(scanf("%s",t)!=EOF)
  {
    int len=strlen(t);
    if(t[0]=='.') break;
    get_next(t,next);
    if(len%(len-next[len])==0)
      printf("%d\n",len/(len-next[len]));
    else
    printf("1\n");
  }
  return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值