HDU 1035--Robot Motion(模拟)

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6422    Accepted Submission(s): 3015


Problem Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 

Input
There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 

Output
For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 

Sample Input
  
  
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
 

Sample Output
  
  
10 step(s) to exit 3 step(s) before a loop of 8 step(s)
模拟题,给定一个操作矩阵,N S W E 分别代表向上,下,左,右移动 给定一个机器人,机器人总是从最顶层开始,列坐标题目会给出,你的任务是判断几步之后机器人会走出这个矩阵(有可能永远也走不出,因为可能会形成一个环)我们虚拟一个墙,就是存字符的时候让它从下标1开始,而在矩阵外层套上一层别的字符,与题目中那4个字符不相同就可以,用来判断机器人是否走出矩阵,然后模拟操作就可以了,注意判断是否形成环,可以设一个数组vis[][],初始化为0,代表所有的子符都没访问过,然后访问过就置为1,当判断到一个字符访问过2次时,说明有环,退出来继续操作就可以了(应该不难想)
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cctype>
#include <algorithm>
#include <vector>
using namespace std;
bool vis[110][110];
char map[110][110];
int i,j;
char bfs(char x)
{
	if(x=='N')
		i--;
	else if(x=='S')
	    i++;
	else if(x=='E')
	    j++;
	else if(x=='W')
		j--;
	return map[i][j];
}
int main()
{
    int m,n,start;char next;
	while(cin>>m>>n>>start)
	{
		if(!m&&!n&&!start)break;
		memset(map,'a',sizeof(map));
		memset(vis,0,sizeof(vis));
		for(i=1;i<=m;i++)
			for(j=1;j<=n;j++)
			cin>>map[i][j];
		i=1;j=start;
		int cnt=1;vis[i][j]=1;
		next=map[i][j];
		while((next=bfs(next))!='a')
		{
			if(!vis[i][j])
			{cnt++;vis[i][j]=1;}
			else
			break;

		}
		vis[i][j]=0;int num=1;
		next=map[i][j];
		while((next=bfs(next))!='a')
		{
			if(vis[i][j])
		    num++;
			else
		    break;

		}
		if(num>1)
			cout<<cnt-num<<" step(s) before a loop of "<<num<<" step(s)"<<endl;
		else
			cout<<cnt<<" step(s) to exit"<<endl;
	}
	return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值