POJ 2479-Maximum sum(线性dp)

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33918 Accepted: 10504

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13
马上现场赛了。。3个人尽然没有会dp的sad。。我只有临阵磨枪了。
题意:给一个数列,求数列中不相交的两个子段和,要求和最大。
线性dp:线性dp的子状态与父状态一般相差一个元素,所以子问题通过添加一个增量而到达父状态。从最小的子问题到原问题,一层一层的状态转移呈现出线性递增的关系,所以称为线性dp。
题解:对于对于每个状态i,求出[0,i-1]的最大子段和以及[i,n-1]的最大子段和 相加求最大的即可。[0,i-1]从左往右扫描,[i,n-1]从右往左扫描。
#include <algorithm>
#include <cstdio>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 50010;
#define LL long long
int a[maxn],left[maxn],right[maxn];
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		left[0]=a[0];
		for(int i=1;i<n;i++)
			left[i]=left[i-1]<0?a[i]:left[i-1]+a[i];
		for(int i=1;i<n;i++)
			left[i]=max(left[i-1],left[i]);
		right[n-1]=a[n-1];
		for(int i=n-2;i>=0;i--)
			right[i]=right[i+1]<0?a[i]:right[i+1]+a[i];
		for(int i=n-2;i>=0;i--)
			right[i]=max(right[i+1],right[i]);
		int ans=-INF;
		for(int i=1;i<n;i++)
			ans=max(ans,left[i-1]+right[i]);
		printf("%d\n",ans);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值