POJ 3267-The Cow Lexicon(DP)

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8252 Accepted: 3888

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2
题意: 给一串无规律字符串,然后给出一个字典,现在要求把上述字符串变成字典中的单词,可以删除任意位置的字符串,求最小删除个数。
dp:可以逆推 ,设dp[i]表示为以第i个字符为起点,然后把从i-L区间内的字符串变成合法所需要的最小删除个数。所以倒着推dp[i]有两种情况 1.删除第i个字符; 2 不删除。
dp[i]= min(dp[i+1]+1 ,dp[k]+d (从i开始往后和字典里的每个单词匹配,d表示匹配成功后所需删除的个数 k表示匹配成功后下一已匹配状态))
 
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,m,dp[310];
char s[310],dic[610][310];
void solve()
{
	dp[m]=0;
	for(int i=m-1;i>=0;i--)
	{
		dp[i]=dp[i+1]+1;
		for(int j=0;j<n;j++)
		{
			if(strlen(dic[j])<=m-i)
			{
				int k=0,t=i;
				while(t<m&&k<strlen(dic[j]))
				{
					if(s[t]==dic[j][k])
					{
						++t;
						++k;
					}
					else
					++t;
				}
				if(k==strlen(dic[j]))
					dp[i]=min(dp[i],dp[t]+t-i-strlen(dic[j]));
			}
		}
	}
	printf("%d\n",dp[0]);
}
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		scanf("%s",s);
		for(int i=0;i<n;i++)
			scanf("%s",dic[i]);
		solve();
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值