myeclipse里工程的jdk使用的1.7版本,其中java compiler最高只能选到1.6的问题(在maven工程中出现的问题) -- 记录

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_16397481/article/details/66968829

在工程里面,引入的是1.7版本的jdk:


但是在java compiler中最高只能选择1.6版本。百度了一些大都是说ide有问题。我查看其他工程发现改成1.7的jkd,java compiler是可以选择1.7的。怀疑是maven工程的原因,在工程下面的一个xml配置文件中:<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
  <installed facet="jst.web" version="2.2"/>
  <installed facet="java" version="1.6"/>
</faceted-project>改成1.7,并且右键点击工程选择maven4Myeclipse-->update project configuration。 

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页