Iroha Loves Strings II

问题 : Iroha Loves Strings II
时间限制: 1 Sec 内存限制: 128 MB

题目描述
Iroha has a sequence of N strings S1,S2,…,SN. The length of each string is L.
She will concatenate all of the strings in some order, to produce a long string.
Among all strings that she can produce in this way, find the lexicographically smallest one.
Here, a string s=s1s2s3…sn is lexicographically smaller than another string t=t1t2t3…tm if and only if one of the following holds:
There exists an index i(1≤i≤min(n,m)), such that sj=tj for all indices j(1≤j<i), and si<ti.
si=ti for all integers i(1≤i≤min(n,m)), and n<m.

Constraints
1≤N,L≤100
For each i, the length of Si equals L.
For each i, Si consists of lowercase letters.
输入
The input is given from Standard Input in the following format:

N L
S1
S2
:
SN
输出
Print the lexicographically smallest string that Iroha can produce.
样例输入 Copy
3 3
dxx
axx
cxx
样例输出 Copy
axxcxxdxx
提示
The following order should be used: axx, cxx, dxx.

#include <iostream>
#include <algorithm>
#include <string>

using namespace std;

int main()
{
	int N,L;
    while(cin>>N>>L)
    {
        string s[105];
        for(int i = 0 ; i < N ; i++ )
        {
            cin>>s[i];
        }
        sort(s+0,s+N);
        for(int j = 0 ; j < N ; j++ )
        cout<<s[j];
        }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值