poj 1962 Corporative Network 带权并茶集

点击打开链接题目链接

Corporative Network
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 3142 Accepted: 1131

Description

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000) will follow with one of the commands: 
E I – asking the length of the path from the enterprise I to its serving center in the moment; 
I I J – informing that the serving center I is linked to the enterprise J. 
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

E查询 I合并

#include<stdio.h>
#include<string.h>
int abss(int a)
{
    return a>0?a:-a;
}
int father[20010];
int dis[20010];
int find1(int a)
{
    if(a==father[a])
        return a;
    int t=father[a];
    father[a]=find1(father[a]);
    dis[a]+=dis[t];
    return father[a];
}
int main()
{
    int t,n;
    char str[10];
    int a,b;
    int i;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            scanf("%d",&n);
            memset(dis,0,sizeof(dis));
            for(i=1;i<=n;i++)
            {
                father[i]=i;
            }
            while(1)
            {
                scanf("%s",str);
                if(str[0]=='O')
                    break;
                else if(str[0]=='E')
                {
                    scanf("%d",&a);
                    find1(a);
                    printf("%d\n",dis[a]);
                }
                else if(str[0]=='I')
                {
                    scanf("%d %d",&a,&b);
                    if(a!=b)
                    {
                        father[a]=b;
                        dis[a]+=abss(a-b)%1000;
                    }
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值